General discussion

Locked

Winsock error?

By ngen255 ·
Hi, I've recently been having a problem with my ftp program. Whenever I try to log on to my schools server, it gives me a Connection failed (10053: Software caused connection abort) error. Doing some research, I've found that this might have to do with a winsock error or something? I came across one website telling me to set my router's MTU setting to 1500, but when I try this, I lose all connectivity. Does anybody know what's wrong? Prior to this, I was using Verizon DSL, but now I have Verizon FIOS with a D-Link DI-524. I'm using Windows XP Pro SP1.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by pctechmike In reply to Winsock error?

If it were a winsock error, you shouldn't be able to connect at all. I did some research myself, and it seems it could be related to your firewall. Try using a different firewall, and see if that solves the issue.

Collapse -

by ngen255 In reply to

tried disabling firewall...no difference

Collapse -

by dmiles In reply to Winsock error?

Winsock error 10053
Winsock error 10053 used to be usually related to network problems, not software. This is no longer the case thanks to anti-virus software that arguably tries to be smarter than it should be.
10053 is a winsock error with the description "Software caused connection abort."

The error happens when the local network system aborts a connection, which might happen if the remote host didn't acknowledge data even after retries.

If you get this error, first see if you have virus scanning software that may be blocking outgoing tcp/ip packets. If you do, make sure that your application is set as a "trusted" application or turn your scanner off, remove it from your machine, drop the CD on the ground and stomp on it several times (if you choose the latter option, proceed with caution. I take no blame for any consequences).

If AV software is not the problem, here are a few things to try:

Ping something on your local network. Do you get a response?
Ping the remote host. Does it respond? If not, problem solved. You can try a traceroute to see if the problem is at the target remote host or somewhere in between.
Is there a firewall between your appliation and the remote host? If so, and the connection has been open for a long period of time with no data transfer, its possible that the firewall has timed out the connection and closed the sockets.

Collapse -

by ngen255 In reply to

ok...ran a traceroute...can you tell me how to use the data? cause I have no clue....it worked up to a point, when it got to the server I'm trying to connect to i think. But the thing is, I can't connect to ANY ftp server.

Collapse -

by Your Mom 2.0 In reply to Winsock error?

Can you to connect to web sites without problems? Did you recently remove spyware?
Sometimes spyware removal programs will remove or corrupt the LSP stack, resulting in problems connecting to the web. When this happens, LAN connectivity still works but internet connectivity gets broken.

Just Googled "lspfix" and found this link that does a better job explaining the problem than I can:

http://www.cexx.org/lspfix.htm

Of course, if you're accessing this web site through the same PC that you're having problems with, then this is not your problem.

Collapse -

by ngen255 In reply to

Poster rated this answer.

Collapse -

by ngen255 In reply to Winsock error?

This question was closed by the author

Back to Desktop Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums