Question

Locked

Winsock Fix broke my VPN & I can't get it back

By traevis ·
I usually connect to a workplace by first connecting to the VPN then using Remote Desktop to access the various other computers in the network. Yesterday, Remote Desktop was not accessing the computers, but the VPN was working fine. (Other remote workers had no problems, so it was something at my end). To the best of my knowledge, nothing had changed with my setup. I tried Winsock Fix to repair the remote desktop problem. It may or may not have fixed the original problem - I can't tell, because now I can't access the VPN. I have tried deleting the original VPN connection and setting up a new one, but no difference. I've tried disabling my firewall, my anti-virus & put my PC in my DMZ - no difference. I'm using Windows 7 to connect to Windows Server 2003. Anybody got any ideas?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Windows 7?

by seanferd In reply to Winsock Fix broke my VPN ...

I doubt there is a valid sockets fix for 7, so you probably broke it.

Where did you get the winsock fix?

Collapse -

Good Question

by traevis In reply to Windows 7?

I downloaded it from Softpedia having googled for Wisockfix Windows 7 - it came up with "compatible with all" versions of windows. Though now I look more closely, it was created in 2004. Is there any way to fix this mistake without reinstalling windows?

Collapse -

Ah, it fixes config...

by seanferd In reply to Good Question

so it likely isn't a problem. The only thing it may have done is to import registry values that aren't good on Vista or 7. (They do have some settings that shouldn't be changed.)

Either way, you already had one problem, but this may complicate things.

...Hmmm. Right, nothing mentioned later than XP in the software files. Since this may have changed TCP stack or winsock settings inappropriately, (like taking RWIN out of automatic setting), you may want to try a repair install.

Running
netsh winsock reset
might help.

Have you had a look in the Event logs to see what error messages might be relevant?

You might try this, just to see if any if there are any LSP problems.
http://www.cexx.org/lspfix.htm
Not designed for Vista/7, so you may not want to actually run a fix if offered.

You can see the LSP cat by doing
netsh winsock show catalog
you could even redirect output to a txt file.

This may help as well, but again, 7 is not mentioned.
http://support.microsoft.com/kb/811259

Collapse -

Two things

by mafergus In reply to Winsock Fix broke my VPN ...

1. Try system restore.

2. Check the documentation on the winsock fix. If it is similar to some of the ones built in the past, there may be an undo option, or it may have created a backup of the file(s) it modified.

Collapse -

Thanks for the thoughts

by traevis In reply to Two things

System restore hasn't fixed the problem unfortunately.

There is a backup button with winsock fix, but it doesn't seem to have actually done anything. Perhaps the functionality was not compatible with Windows 7. Or possibly I'm not finding the backup file, but I've run a number of searches through the computer & can't find anything resembling it. Thanks for the help anyway. If you've got any other ideas I'm happy to give them a go. Otherwise it's probably going to have to be a reinstall job.

Collapse -

try this

by jmclellan In reply to Thanks for the thoughts

this might be worth a shot, try sfc /scannow from a cmd prompt.

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums