Question

Locked

Wireless Networking Issues Between 2 XP machines

By david.wigley ·
Hi I'm having problems sharing files between 2 computers through my Wireless Router.
Set-up is:
Modem cabled to Wireless Router.
Computer A is an XP laptop that connects to the internet wirelessly.
Computer B is an XP pc that connects to the internet wirelessly also.
I have run the network wizards on both machines, setting up network HOME1, but A and B cannot see each other.
On laptop A, under My Network Places > Entire Network > Microsoft Windows Network, the network HOME1 is displayed, and under this it only shows laptop A.
On pc B, under the same structure, HOME1 is shown, but nothing listed under it (not even pc B).
Can anyone help with suggestions as to how I can get the pc to show up under the network, assuming this is the only problem to get the machines to see each other?

There were no errors when I ran the wizard on either machine. All help/suggestions gratfully recieved.

Thanks

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Maybe its the firewall

Sounds like the firewall is blocking the computers "talking" to each other try disabling them on both machines and see if it works. If it does work you know it is the firewall. Remember to them back on!

Collapse -

do you

by Sue T In reply to Maybe its the firewall

do you have any shared folders on the computers?

Collapse -

Shared Files

by david.wigley In reply to do you

Hi Sue T,

Yes, I have shared files on both machines;
The laptop's shared files appear as a list under my Network Places> HOME1> laptop A> etc., but the pc B does not (since the pc isn't even listed there).

I assume I don't need to share the root directory (C:) to display the machine name as long as a sub folder is shared (this is the case with the laptops at least).

Thanks.

Collapse -

No $ Right?

by rkuhn In reply to Shared Files

There shouldn't be a $ in the share name or else it is a hidden share.

Collapse -

no $ present

by david.wigley In reply to No $ Right?

Hi, no, there are no $ symbols in the Share name. I usually just leave this name as the default (the actual folder name on the computer).

Thanks.

Collapse -

Update...

by david.wigley In reply to Maybe its the firewall

Thanks for this Zak,
I have tried diabling the firewall on the pc only, but this didn't seem to make any difference. I will try diabling it on both machines next, but the fact that the laptop can see itself on the shared networks makes me think the problem is solely with the pc. Is there a specific exception within the firewall settings that should be on/off, other than the priter and file sharing option?
Thanks, Dave

Collapse -

Can you map a drive...

by taboga In reply to Wireless Networking Issue ...

...from one to the other? Might try mapping a drive to each one and then restarting the sytems and see if they show up in MNP then.

Collapse -

Check the following

by DaveDXB In reply to Wireless Networking Issue ...

1-----------------------
Both computers are on the same WORK GROUP name. By default it is sometimes called WORKGROUP or sometime MSHOME, whatever it is called, just make sure the computers are on the same work group name.

Richt Click "My Computer" > Properties > Computer Name > etc.

2-------------------
Switch of built in windows firewall to test

3-------------------
Manually input IP address and gateway.

PC A
192.168.0.1
255.255.255.0
192.168.0.1

PC B
192.168.0.2
255.255.255.0
192.168.0.1

4----------------------------
Make sure protocols are installed in Netwotk Connections.

-Client for Microsoft Networks
-File and print sharing for microsoft networks

5-----------------------
Make sure SERVER service is running (by default on windows xp pro it is set to run)

start > settings > control panel > Administrative Tools > services > server (automatically)

6-------------------------
Security permissions

:)

Collapse -

Still Not Happening...

by david.wigley In reply to Check the following

Thanks for all your replies. I had to wait til the weekend to give this a good go, but have still come up empty handed.
I tried following the above steps (nice and simple).
Points 1 & 2 are fine. Not sure how to manually input the address and gateway in 3. Any chance you can give more details? The automatically assigned ones look very similar to this anywa, with both computers being assigned addresses from my router. Points 4 & 5 were fine - all running on both PCs.
Again, not sure about point 6. Can you give more details about the security permissions?

Another thing I've noticed, when I add a shared (network) drive, this does not automatically appear under My Network Places. I go "right click>Properties>Sharing & Networking", and add a shared drive name for it, and the folder icon get the little hand on it to indicate it's being shared on the network. However, it still doesnt appear in the My Network Places. The opposite is also true (when I unshare a previously shared folder, the little hand disapears, but it remains in the My Network Places directory).
Is there some potential file/service not running that would actively update/refresh these settings?

Thanks again for any help.

Collapse -

=(

by DaveDXB In reply to Still Not Happening...

Never thought sharing a file would be that complicated hahaah

-Open any folder

-tools > folder options > view > scroll down to the last check box that says "use simple file sharing (recommended)"

-Uncheck that

Now if you right click on the shared folder and select "sharing and security...".

You will notice a new tab called "Security"
What you just did was enable a hidden menu for advanced users who want to share folders. This menu give you more control of how you want to share your folder.

-who can access it
-Can they delete (manipulate) files
-Can they put file sin ur folder or only read
-etc.

For testing purposes, make sure the user name "everyone" has full access. This means EVERYONE should be able to see and access your folder.

Earlier i mentioned the IP addresses...Dont mess with that if your wireless router is already configured and your computers are already properly and successfully picking up IP addresses.

There are two windows services needed for windows to be able to share and brows shared folder on other computers. A list of windows services are available at

menu > settings > control panel > Administrative Tools > Services


Make sure both
-Worstation
-server

Are set on AUTOMATIC and are RUNNING / ENABLED

These two services are needed for sharing and browsing through network shared folders.
-

Back to Networks Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums