Question

Locked

Word doc. links not working when downloaded from SharePoint site

By jradzano ·
Hi everybody,

Please forgive me if this has already been posted elsewhere. We are
currrently running SharePoint 2003. It was just brought to my
attention the other day that we have several word documents posted
to one of the sites. This site has a Word doc that contains URLs that
point to other word documents. This one itself was uploaded at the
same time as the other files it points to. Now here's the problem:
When being viewed from Internet Explorer on PCs everything works
correctly. However when the document is viewed from Safari or
Firefox for either the PC or the Mac, the urls in this file that point to
the other documents do not work. I file not found error results. I did
a little digging around and I think the reason why the links work in
Internet Explerer is because of Active X. Also, with FF or Safari, the
file is not opened at its current location. It is downloaded, then
opened. I think this is what is causing the problem. When the file is
downloaded, since there's no ActiveX in Safari or FireFox, the URLs
are not changed to point to the other documents on the SharePoint
site. They are still in the original form. I tested this by downloading
one of the target files to the same location and then clicked the link.
The correct document then opened. Please correct me if I am wrong
on any of this. But is there a way to get these links to update
correctly without having each viewer download all of the documents
from the site for the links to work?

Thanks for any help you can provide.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Software Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums