Question

Locked

WSUS 3.0 registry problems on XP boxes

By larry.kahn ·
We are using the WSUS 3.0 services to push all of Microsoft updates out the over 300 clients on our network. For the past several months, the application worked beautifully. However, for the past several weeks I have noticed that many of the clients are not receiving their approved updates. I have checked all of the clients that are working correctly with the clientdiag.exe and noticed that the registry setting for the Windows Update are missing. I stopped the Automatic Update services re-inserted the correct setting back into the registry, re-started the Automatic Update services, and waited. After several hours I check the clients again and saw that the registry setting are once again missing. Since I am the Network Admin, I know that I have the correct permissions to adjust the client?s registry. I checked the Group Policy on my (3) 2003 Active Directory machines are set according to Microsoft specs. 90% of the client machines are receiving the updates. I was wondering if anyone would be able to help me identify or resolve this issue.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Check your GP settings.....

by bclark In reply to WSUS 3.0 registry problem ...

The first thing that comes to mind is that another GP is "overwriting" the update settings.

Are you using the Computer config or the User config when editing the GP? (should use computer config)

Are users in OU's with a WSUS GP? (should just use computer accounts, as user accounts seem to confuse it)

Collapse -

Also check WSUS settings....

by bclark In reply to Check your GP settings... ...

Are they set up to receive their WSUS config from WSUS or from AD settings?

Collapse -

WSUS 3.0 registry problems on XP boxes

by larry.kahn In reply to Also check WSUS settings. ...

The WSUS config is configured using the AD settings.

Collapse -

WSUS 3.0 registry problems on XP boxes

by larry.kahn In reply to Check your GP settings... ...

The GP settings are on an OU in AD.
The strange thing is that it did work with 3.0 and then all of a sudden the registry settings were being wiped out for WSUS. I could understand it on one or two machines, but not every one of the computers!
I wrote a batch file to add the parameters to the registry to simplify the process. I refreshed the screen to refresh the registry, checked the settings with the ClientDiag.exe application, and was sitting there waiting for the WindowsUpdate.Log to finish when the settings that I had just applied to the registry went away. I immediately went to the gpedit.msc on that machine to check to make sure that it was not causing the problem. There were no settings applied, I then went to the each of the Active Directory servers (3 of them) and check the Default Global settings. No setting. (According to Microsoft (MS), there should be none for WSUS). I again check the OU properties and they were set according to MS.
I makes no sense. Since the registry settings are going away, the WindowUpdate.log is full of errors. With NO updates being applied.
Got any ideas?

Collapse -

IP or DNS for specified update location?

by IAmLegion20ll In reply to Check your GP settings... ...

Have you tried using both the IP address and/or DNS name for your WSUS server in your GPO? Don't know if you can do it for one of the problem machines, but that has (weirdly) fixed problems machines for me.

Back to Software Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums