General discussion

Locked

WXP not finding >8 char net folder name

By mario.pineda@landisgyr ·
I am replacing a manufacturing machine running W2K SP4 with one running WXP SP2. This machine is used to control / monitor PLC?s, among other things. After a few initial bumps, every application runs fine except for a few QuickBasic programs running in DOS.

I have identified the problem and it?s that the QB apps try to access files residing on a Netware 4.11 network folder named "calibration?, which is more than eight chars long. If I rename the folder to ?calibrat? (8 chars), the apps run normally and problem solved.

The issue is that there are several other users, both human and non-human, that write to the same folder through Excel macros.

It seems to be a lot more work to change those macros than to solve compatibility issues.

I have rolled back to SP1 on WXP but the issue persists. Setting application compatibility to DOS is not an option since the apps reside on a network drive and that?s the specific message I get when attempting to set compatibility.

Hope somebody has some ideas, as I am running out of them.

Thanks.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by rindi1 In reply to WXP not finding >8 char n ...

Which netware client are you using on the XP machine? is it the built-in netware client or is it a Client you got from Novell? Try the other client, that may help.

Collapse -

by mario.pineda@landisgyr In reply to

Poster rated this answer.

Collapse -

Thanks for your reply.
I have tried both (Client Service for Netware and Novell Client for Windows v4.9SP2) and still no sucess.
Under the Novell Client properties the DOS long name support is set to On.

Collapse -

Point value changed by question poster.

Collapse -

by Choppit In reply to WXP not finding >8 char n ...

I've come across this issue before and resorted to using short filenames. Here's a link that may help with understanding the limitations of the DOS name space.

http://www.avanti-tech.com/tips/longname.pdf

Sorry, I can't be of more assistance but it looks like you may have no choice but to change your folder names.

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums