General discussion

Locked

XP and 98 non-network

By Fitch ·
I have an XP machine as the gateway and one 98 client, using a crossover cable to make the network.
Everytime I switch the computers off, everything is forgotten and the network doesn't exist when I switch on again. This has been driving me up the wall for about 3 months now.
I run the network wizard on the XP gateway and get yet another printer in my network (I now have 15 and no way to get rid of them) and still the 98 will not connect to the internet through the gateway.
Is there somewhere a step by step instruction to tell me what exactly the network settings in the control panels and the internet settings in the 98's explorer should be, as I now haven't a clue as to what I've changed and when. I have spent about 4 hours a night for the last 3 months trying to get it back together, and no, the wizard does not work any more.
At the last look, the 98 was

TCP/IP properties: Specify an IP address ticked 192.168.0.100
Disable WINS.
Installed Gateway 192.168.0.100
Disable DNS.
Bindings: Client for Microsoft Networks and File & printer sharing both ticked.
NetBIOS: Enable netbios ticked but greyed out.
Advanced: Allow Binding to ATM set to yes.

DE220 properties:
Driver type: Enhanced mode 32 bit & 16 bit driver ticked.
Bindings: TCP/IP ticked.

Client for Microsoft Networks:
Logon and restore network connections ticked.

File and Printer Sharing:
Browse Master enabled
LM Announce Yes

In Internet Explorer Tools/Internet Options/connections/LAN settings/Automatically detect settings ticked.

On the XP gateway:
Local Area Connection properties:
Name Service Providor: Windows Locator
Internet Protocol properties: set to : Use the following address: 192.168.0.1
subnet mask 255.255.255.0
Use the following DNS Server addresses is ticked with no entry.
Advanced:
IP Addresses window has 192.168.0.1 in it .
and Automatic Metric is ticked
DNS:
Append primary and connection specific DNS suffixes is ticked, as is "Append parent suffixes
of the primary DNS suffix" and "Register this connection's addresses in DNS"
WINS:
Enable LMHOSTS lookup is ticked.
Enable NETBIOS over TCP/IP is ticked
Options:
TCP/IP filtering
Proprties of above all set to "permit all"
I think that's everything that's ticked.
Any ideas?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

A few thoughts

by HereInOz In reply to XP and 98 non-network

If you are going to specify an IP address on the 98 machine, you will need to specify the gateway as 192.168.0.1, and enter the DNS server IP addresses of your ISP.

Otherwise, set everything automatic

Alan

Collapse -

a few extra thoughts

by itctonguy In reply to A few thoughts

I agree with HereInOz that the gateway of the 98 machine should be set to 192.168.0.1, but I believe the DNS server address on the 98 machine should be set to 192.168.0.1 (Win XP computer), and the Win XP computer DNS server address should be set to the DNS addresses of your ISP. (You can obtain these addresses by calling the tech support number of your ISP and asking them for their DNS server address(es).

Collapse -

Fixed.

by Fitch In reply to XP and 98 non-network

O.K. I'd had enough!
I found that the XP (Home ) had several "unneccessary" files missing. This is an e-machines computer with a cut-down version of Home, and a "Recovery CD" was all that came with it.
I installed XP Pro, and hey presto everything works. I also got rid of Mcafee and replaced it with Norton.
Everything is stable now. Thank you for your insight. It helped to track down the "culprits"

Back to IT Employment Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums