General discussion

Locked

xp - dos app - lose network printer

By lbarthels ·
I have a DOS app which requires the port to be specified as LPT1 etc. The printer is an HP4050, not a print server, just a shared printer on an XP workstation. Some machines are fine with just setting up a network printer with LPT1, others I haveto use the net use LPT1 \\sharename etc \persistent:yes. When using the net use, I randomly lose the connection to the DOS app. Windows knows its there, but my app does not print. It thinks the printer is there as there is no error, but nothing prints. Anyone got any thoughts on why the DOS print jobs don't print?

I am getting desperate..Microsoft offers no help. Yes..no comments about the DOS app, but it is app specific and no Windows based replacement yet.

Thanks,
Laurie

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

xp - dos app - lose network printer

by Gigelul In reply to xp - dos app - lose netwo ...

Don't use "net use lpt1: \\share..." on the computer where was connected the share printer.
If you use roaming profiles and the users logon on different computers, the maped LPT must be "delete" when they use a computer with a printer phisicaly attached to that computer.
If a user logon on a computer with an attached printer and also have a map to LPT1 to other share printer, when he will try to print someting from your DOS app the job is losed.

Collapse -

xp - dos app - lose network printer

by lbarthels In reply to xp - dos app - lose netwo ...

Poster rated this answer

Collapse -

xp - dos app - lose network printer

by rmm In reply to xp - dos app - lose netwo ...

Net use should work. Are the computers connected in a server/client network or peer-to-peer workgroup? If you are connect in a workgroup, which means you are not part of a domain, you might have to an username and password to connect to that printer (look in the help section net use). Can you print anything else to that printer in DOS? Has it always work before now? Can the DOS app be re-installed? How are you connecting to the DOS app? Is it installed on your local computer or is it on another computer? Sorry for so many questions, but I need some more information in order to figure it out.

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums