Question

Locked

XP explorer.exe terminates soon after log-on.

By Healer ·
I have an old Windows XP Pro computer. It boots up and I can log on without any problem.

Some seconds after log-on, everything including all the shortcut icons and the bottom task bar on the screen disappears. It looks like the explorer.exe has terminated.

This time I have brought up the task manager before things disappear. I noticed for sure the explorer.exe has definitely terminated.

Every time I re-start the task explorer.exe it would only stay up for a little while, not enough time for me to do anything.

Then I found http://www.squidoo.com/explorer-exe and http://www.ehow.com/how_4592369_problem-windows-xp-taskbar-disappears.html which were essentially the same. I followed that and copied an "explorer.exe" from a good XP system and pasted to the Windows directory exactly as instructed. When I restarted I got the error message "The procedure entry point SHCreateThreadRef could not be located in the dyynamic link library SHLWAPI.dll.". So I overwrote the original suspicious "explorer.exe" with the known good one and changed the registry entry back to what it was. However the same error message came up. I just want to get it back up and running so that I can scan for virus or for whatever it may be.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Smells like infection.

by Leonardo_C In reply to XP explorer.exe terminate ...

The explorer.exe you used did not match the one on your system, thus causing the SHLWAPI.dll issue.

If all you need is the system up for virus/spyware scanning (looks like it needs it), forget explorer and just run your scans from Task Manager or a CMD window and in safe mode.

Collapse -

I have lost the original OS CD

by Healer In reply to Smells like infection.

for the system in question. That's why I try to save the system without re-installation. I don't seem to be able to eliminate the error. I have got the file "explorer.ex_" from another OEM CD and expanded it and put it in the Windows directory but I still get the same error.

If I manage to eliminate the virus or whatever in there it might still be a challenge to use the system unless the error is caused by virus.

I have done sfc /scannow and found no problem. I have also done "regsvr32 /s shlwapi.dll" file but it wouldn't make any difference.

Collapse -

Ok

by Leonardo_C In reply to I have lost the original ...

You need to grab a copy of the latest explorer in the drive. Do a search in a dos box (dir explorer.* /s/a/p) from the root dir and copy the latest explorer.exe (by date) to the right place.
Long day/night, brain fried or I could give you more specific instructions.

Collapse -

I did what you said but ...

by Healer In reply to Ok

I brought up the command prompt and did exactly as you said. I found the latest one was the one I put in lately. So I disregarded that one and copied the one from \WINDOWS\system32\dllcache to C:\WINDOWS. I rebooted the system and got a different error message, "Windows Explorer has encountered a problem and needs to close." So I put the other one back in.

I don'tknow what the one in C:\Windows\Prefetch\EXPLORER.EXE-082F38A9.pf was as the size was really different.

Collapse -

you can do a repair using the CD but there is a specific

by CG IT In reply to I have lost the original ...

http://pcsupport.about.com/od/operatingsystems/ss/instxprepair1.htm

this is a repair not reinstallation

it doesn't change the product key or require it.

about the only way I know of to repair something like you've done.

Collapse -

No repair option.

by Healer In reply to you can do a repair using ...

For some reason I didn't see the Windows XP Licensing Agreement screen come up. At one time I supposed I saw the option of using Recovery Console available, then when I did it again there wasn't. There was no repair option available at all. When I did it again and again, there was only option of setting up and next go to the option of whether I want to have the partition formatted. Was it because I was not using the original CD or the XP Pro installed on the computer was too out of date.

Back to Malware Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums