General discussion

Locked

XP Home boot hangs at mup.sys

By baz_shaw ·
Trying to help a friend with what turns out to be a common problem (after researching on the www). Windows XP Home running on a Dell Dimension, nothing sepcial about it or its configuration. All of a sudden decides to go into a booting loop, and if trying in Safe Mode, occurs at the same time each loop - as mup.sys device driver loads.
There is a lengthy forum thread about it on Computing.net (http://www.computing.net/windowsxp/wwwboard/forum/30471.html)

Next time I visit my friend, I will try Disabling mup.sys from the XP Recovery Console, but I'd really like a more satisfying explanation and fix, if anyone can offer one.

Thanks

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by dmiles In reply to XP Home boot hangs at mup ...

Well - my solution is to change the computer type in Control panel (System- Hardware- Computer)from 'Uniprocessor ACPI' to 'Advanced Configuration and Power Interface'. I think MUP.sys hanging WinXP is a power problem NOT a porblem with MUP.sys. I tried everything that everybody else tried - changing and removing hardware, disabling mup.sys, rebooting again and again, etc etc. All a complete waste of time! The problem seems to be that changing any hardware (eg removing the USB mouse) makes WinXP start and then changing it again makes it stop - and it also seems to be incosisent so it sometimes works and seomtimes doesn't. So I even got to the point of removing a memory module (everything else was off!) and it started working. Any way, I then went into Control panel and applied the changes above and it has worked fine ever since, even when removing or adding hardware. I have now attached all my hardware again and it has worked fine for about 10 reboots.

Collapse -

by baz_shaw In reply to

Sorry, no points awarded for plagiarism - http://www.annoyances.org/exec/forum/winxp/1073225053

I"ve read all the solutions on Annoyances.org as well as Computing.net Best answer there was resetting the ESCD, but ewven that didn't work!

Collapse -

by LMon In reply to XP Home boot hangs at mup ...

Have you inserted the win xp cd and attempted to do a reapir?

Have you tried getting into safemode then doing a system restore to a date where it worked?

Collapse -

by baz_shaw In reply to

Yes I did all the usual stuff with Recovery Console. I went so far as to replace the mup.sys file, although I didin't think that was the issue, just the marker before the file causing the problem. Unfortunately it fails before a ntbootlog can be made, so I don't actually know what follows mup.sys. I Disabled mup.sys from RC and it just halted at the file before it.

It stalls & reboots regardless of the boot mode - Safe, Safe with . . ., Last Known Good etc etc.

Its a puzzler alright! Anyone got a clue?

Collapse -

by TechieRob In reply to XP Home boot hangs at mup ...

Unfortunately Mup.sys is one of those critical system files that can either randomly break, or break due to an unexpected system change (i.e. a virus). If safe mode freezes at mup.sys it is a fair indication that this file has been corrupted.

It is possible to get around this by booting into safe mode with a command prompt, then hitting alt cntrl del and selecting "new task" then typing in "explorer" (minus quotes)

Through this interface it is possible to run legacy devices such as regedit or msconfig to see what precisely is going on.

The bad news, however is that the only real remedy to fix this file is to reinstall windows

Collapse -

by baz_shaw In reply to

Thanks TechieRob. I kinda resigned myself to this (reinstall XP) being the only solution, but your answer helped confirm this for me.

Collapse -

by baz_shaw In reply to XP Home boot hangs at mup ...

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums