General discussion

Locked

XP Home fails to format partition

By PCTech In AZ ·
I have a bugger system here that refuses to completely format a primary partition with XP Home CD. After creating one single partition and choosing Full Format NTFS. It goes all the way to 100% and then tells me on a blue screen that it could not format the drive. Every time.
I've swapped every dern thing there is. HDD, CPU, RAM, Video, motherboard, removed PCI devices, tried a different HDD, I tried another XP Home CD, I tried using a different CD-ROM drive. Always the same thing.
One time it did format but only when I did Quick Format. It also failed other Quick Formats in the same manner. But XP was unstable and locked a lot.

It now has an ECS K7S5A, AMD Athlon 1.2, SDRAM, AGP video, Seagate HDD. I'm just stumped, I thought that dumb Shuttle AK12 MB was the problem.

I tried using the XP Home CD to format the drive on another system, it worked, but I can't really stop the setup process to switch back to the other system, besides, I don't feel that's a proper solution anyway,it should work. What the heck? Any educated guesses? I've now changed the power supply, still no go.

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Here's the actuall error message

by PCTech In AZ In reply to XP Home fails to format p ...

Setup was unable to format partition. The disk may be damaged.
It's an IDE drive, the drive is just fine, I've also swapped cables.

Collapse -

What kind of drive is it?

by MTBerJim In reply to Here's the actuall error ...

I've run in to this with some drives that used the bios tools like maxblast and the WD one. If it's a WD use the tool and restore to factory spec's, you should be ok after that. If it's anouther try the Norton tool and boot to it, then use disk doctor.
Good luck, Jim D.

Collapse -

It's just plain possessed

by PCTech In AZ In reply to What kind of drive is it?

The original drive was a Seagate, I've also tried with an IBM, both 40GB. No other HDD utilities used.
Pretty much everything is now new, MB, HDD, RAM, PS, Video, CD-ROM, Floppy, Cables. It's now even completely out of the case and sitting on the bench.
It did finally install and format good two times in a row, so we let it go and did all the XP updates. Then, two days later, I plugged back in the Lan connector and suddenly it went into some kind of sleep and didn't come out of it.

Anotherstupid thing it does is, when a modem is in one of the PCI slots, we've tried two kinds, it won't boot. Now, again, it's not even booting at all, even after a BIOS reset. The very last resort is that it's a bad CPU that is causing funky intermitten problems. We've tried two different Athlons but both we're also on the previous MB.
There's just nother left to try.

Collapse -

Sounds like the main board

by MTBerJim In reply to It's just plain possessed

It's the only common thing left. Will the board post? Remove all the PCI cards and disable the onboard devices and set the BIOS to the failsafe state and try it again.
Good Luck, Jim D.

Collapse -

by djent In reply to XP Home fails to format p ...

I assume you are trying to create a NTFS boot partition. You cannot create a NTFS boot partition larger then 1023 cyl or 7.68 MB, if you convert a FAT32 boot partition larger then this you are doomed to boot failure at some point. See MS KB on NTFS boot partition limitations or executive.com KB, they have a good disertation on why. Thats why most OEM restore disks create FAT32 drives, no ability to partition, no NTFS, no support calls, no good file system.

Collapse -

Have had the same problem

by Securitytech In reply to XP Home fails to format p ...

I had the same problem with a XP pro disc. Assuming you are trying to go NTFS, try to format the disk/partition FAT32 and then convert it to NTFS later. That worked for me.

Collapse -

read djent .... and this

by bootstrap In reply to Have had the same problem

Without doing all the nitty gritty, your boot partition should be fairly small. NTFS pukes when you try to create an NTFS larger than authorized (I always forget the answer - but it is just shy of 8Gb.)

You can defeat this by putting the disk inanother machine with the proper version of NTFS and preformatting it there with nothing in it. It will run fine ....

UNTIL ....

... you defrag and some critical boot file is moved to a spot outside the 8Gb's that the hardware can see early inthe boot process - before the os is initialized. Once that happens, the file is "gone" insofaras booting is concerning and it will NOT boot.

You can beat this by buying a 3rd party defragger and freezing all the boot files.

However, the BEST solution is to make a small boot/system partition - 3-4 GB is more than ample. Make it 5 GB and all your main apps will fit with room to spare - put all the data in another partition/volume.

Enjoy

Collapse -

by djent In reply to read djent .... and this

The limits are 1023 cylinders or 7.68 MB.

Collapse -

8GB limit no longer applies

by RusselB In reply to

Since NT 4.0 SP4, the 8GB (or 7.68 to be exact) limit hasn't applied. My XP system has a 30GB boot/system partition.
This users problem may be that XP doesn't support creating FAT32 partitions greater than 32GB, even though it can happily use them if they were created under Win98 for example.

Collapse -

by djent In reply to 8GB limit no longer appli ...

I believe XP still uses NTFS5 which does impose boot partition limits. You can create an NTFS partition of almost any size by formating it in a running NT machine but risk boot failure with sizes over 1023 cylinders.

Back to Hardware Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums