Question

Locked

XP Home Laptop starts in safe mode, hangs@login in safe/w/network or normal

By jasper-tr ·
Hi,

A friend has been having problems with a laptop that is 'slow' and asked me to take a look, I uninstalled a bunch of toolbars and the Symantic LiveUpdate thing (using the add/remove programs control panel), (They use Avast).

When the machine is restarted it gets to the enter password screen and after 10-15 seconds (during which the harddrive is being accessed) it hangs solid, no mouse pointer, no caps lock light etc.

Safe mode works fine, Safe mode + networking hangs in the same place.

I've tried a last know boot, system restore, and disabling automatic restart, nothing from any or them.

I've also run the norton removal tool, no luck.

Also tried booting with wireless switched off, and no network cable, again no difference.

I've looked in the services list, and nothing appears to be obviously wrong, tho there is quite a bit of stuff in there.

So - am i right in assumeing that whats happening while the hard drive is being accesses before the login prompt is services being started?

If so Is there a way to get a list of services that are not started in safe mode, but are started in safe mode + networking (sm+net)?

and would one of those be the culpret?

Also is there anyway to find out what windows thinks it's using as a firewall - it might be trying to use a dead install of symantec.

Also does anyone know of a tool that runs in safe mode that lists the services that windows would start in normal mode or sm+net, and lists them in the order that they would be started? I could go through them one by one and see what happens.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

thats ruff....

by ---TK--- In reply to XP Home Laptop starts in ...

If you go to "Start"-->"run"--> type "msconfig" that will show everything that loads on start up, and you can enable or disable just about anything. Be careful! Have you tried running chkdsk?

Collapse -

chkdsk

by jasper-tr In reply to thats ruff....

I've run the disc error checker from right clicking on the drive and it didn't find any problems.

Update: rebooted with logging and with the wireless switched off and it worked ok, switched the wireless on and then it hung, so definatly wireless related.

Collapse -

hm....

by ---TK--- In reply to chkdsk

I want to say I have seen this before, but I don't recall what the solution was... what is the model of the laptop?

Collapse -

Model is...

by jasper-tr In reply to hm....

Toshiba Satellite M100

I can trigger it consistently by switching on the wireless now, The wired cable works fine.

Tryed re-installing wireless drivers and wireless config app, no luck

Collapse -

Have you downloaded the newest drivers

by Jacky Howe In reply to XP Home Laptop starts in ...

http://drivers.softpedia.com/get/Other-DRIVERS-TOOLS/INTEL/Intel-PRO-Wireless-2200BG-2915-3945-3965ABG-1050.shtml

Collapse -

yes.

by jasper-tr In reply to Have you downloaded the n ...

I've tried the latest intel drivers, and then the latest toshiba drivers, no luck.

current state is this:

Laptop boots fine with wireless switched off, switch the wireless on -> view available wireless networks -> refresh, the network i expect to see appears, select it, it starts aquiring an ip address and then hangs.

So it's something that hooks the network stack i think.

Going to try with the sysinternals tools running at the same time.

Collapse -

Interesting discussion here

by Jacky Howe In reply to yes.

with a few possible solutions.

http://www.tdaxp.com/archive/2005/02/05/acquiring-network-address.html

Collapse -

different hang i think

by jasper-tr In reply to Interesting discussion he ...

In my case the laptop hangs entirely (freezes, locks up), the mouse stops moveing, caps lock light stops working.

I suspect LSP's at the moment, will do the thing with netsh that lets you reset them.

busy with other stuff atm.

Back to Hardware Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums