Question

Locked

XP Logs off after logon

By barry ·
Please Help! Pc uses XP pro. Boots up to logon screen, user types in username and password, starts logging in, desktop background appears, then a window pops up and says "Logging off" and it goes back to the logon screen. This happened after downloading updates for AVG anti-spyware. When the download completed, a window popped up saying that the connection has been idle for 20 minutes (which was NOT the case as I was sitting there watching the progress bar), but I clicked "Disconnect" and the PC the rebooted with this problem. Also, the logon screen has changed - it used to boot up with the Icon type login screen (each user has an icon) but now boots to the classic style login, where user has to type his name and password. The PC can boot up in safe mode.
How can I stop it from wanting to logoff?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

logoff issue in Windows XP

by Jacky Howe In reply to XP Logs off after logon

Enter the Recovery Console

Boot the system using the Windows XP CD-ROM. In the first screen when the Setup begins, read the instructions press "R" (in the first screen) enter the Recovery Console. Type-in the built-in Administrator password to enter the Console. You'll see the prompt reading C:\Windows (Or any other drive-letter where you've installed XP)

Type the following command and press Enter.

CD SYSTEM32
(If that does not work, try CHDIR SYSTEM32)
At the prompt type in
COPY USERINIT.EXE WSAUPDATER.EXE

Quit Recovery Console by typing EXIT and restart Windows.

You'll be able to login successfully as you've created the wsaupdater.exe file (now, a copy of userinit.exe)

"WARNING MODIFYING REGISTRY INFORMATION IS DANGEROUS"
Backup the Key before making changes.

Now, change the USERINIT value in the registry
Click Start, Run and type REGEDIT. Navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

In the right pane you will see that the value of the Userinit key is incorrectly set to "wsaupdater.exe,"


In the right-pane, change the value of Userinit to C:\WINDOWS\system32\userinit.exe,

Type the above value exactly as given, including the comma. Also, change the path to userinit.exe appropriately if Windows is installed in a different drive.

Close Registry Editor and restart Windows.

Back to Malware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums