General discussion

Locked

XP PC's Do Not See 98 PC's

By qballrail ·
I have a small home network consisting of 4 PC's, 3 run XP and 2 run 98SE. (one is Dual-boot but same NIC) All XP PC's can see each other and 98's can see the XP machines but not vice-versa. Also, note that the 98's can see each other. I have installed IPX/SPX on each one. All are in the same workgroup, configured accordingly connected by a passive hub. Previously, I was able to see both configurations without difficulty. Any ideas?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

XP PC's Do Not See 98 PC's

by motorcyclemat In reply to XP PC's Do Not See 98 PC' ...

install NETBUEI on the 2 98 machines and also on the XP machines.
Right click on network neighbourhood and click properties, ADD protocol, microsoft, netbuei (on 98 machines)
can do this, also try the properties on My Network Places on the XP machines and try and find a tickbox with Enable NetBIOS over TCP/IP..tick this on all XP systems. W98 uses netBIOS to communicate and XP uses TCP/IP..that should fix problem, if not, let me know.
hausermannit@yahoo.com.au

Collapse -

XP PC's Do Not See 98 PC's

by qballrail In reply to XP PC's Do Not See 98 PC' ...

Sorry, no go. But thanks for the input. If anything, that config only blinded all PC's to each other and only allowed internet access. I guess I'll have to keep searching. Again, my thanks.
JH

Collapse -

XP PC's Do Not See 98 PC's

by qballrail In reply to XP PC's Do Not See 98 PC' ...

I should have mentioned this earlier.. with that configuration previously, same problem. NetBEUI was installed along with IPX/SPX on all machines. But when I removed NetBEUI, everything worked. The other fact is that this is a new install on one PC. What the ****, I'll try your suggestion, Matty.. what've I got to lose, it's not a business network anyway. Oh, this is XP Pro, not Home. In fact, when all I ran was 98, NetBEUI worked just fine. Funny, I've been told that just TCP/IP will work, but I'm not routing.

Thanks for your suggestion, I'll try it again and get back to you.

Collapse -

XP PC's Do Not See 98 PC's

by BobHo In reply to XP PC's Do Not See 98 PC' ...

I would dump all of the other protocols and just run tcpip along with Client for Microsoft Networks and have all machines see each other. I do this at home and have not had any problems.

You will need to assign static ip's to each machine in the same range (ie 192.168.0.x) along with the subnet 255.255.255.0. You already have them in the same workgroup so this should do it.

Enjoy,

DrBob:&gt

Collapse -

XP PC's Do Not See 98 PC's

by qballrail In reply to XP PC's Do Not See 98 PC' ...

Your solution would work with a router, from what I understand. However, I tried it without but I lost not only all internal network connectivity but my internet connection as well. Thanks for trying.
JH

Collapse -

XP PC's Do Not See 98 PC's

by BobHo In reply to XP PC's Do Not See 98 PC' ...

OK, since you are using ipx/spx let's look at some settings.

It appears that xp installs netbios for ipx/spx automatically when you install ipx/spx. This is not true for win98. In Win98, after installing the IPX/SPX protocol and re-booting, go back to the protocol and select "I want to enable NetBios over IPX/SPX". Do this for each win98 machine.

Now check the win98 bindings. For ipx/spx make sure that the box next to each of "Client for Microsoft Network", "File and printer sharing for Microsoft network" and "NETBIOS support for IPX/SPX compatible protocol" is checked. While you're there, click on the "Netbios" tab on top and ensure that the box next to "I want to enable Netbios over IPX/SPX" is also checked.

On each Win98 machine, do not forget to unbind the TCPIP protocol for LAN traffic by clearing the checkboxes for "Client for Microsoft Networks" and "File and printer sharing for Microsoft Networks" in the properties settings for tcpip. Also make sure that the "I want to enable NetBios over TCPIP" is unchecked.

Look at bindings in XP. Click on "Start", then "My network places", then "View Network Connections", then click on your "local area connection" to hi-light it. Once there, click on "Advanced" on the top menu bar and then on "Advanced Settings". You'll then see a tab on top called "Adapters and bindings". You'll see "File and Printer Sharing for Microsoft Networks" with the protocols that are bound to it. Ensure IPX/SPX is there and checked. Also, ensure TCPIP is unchecked as you do not want TCPIP for your LAN once you decide to use IPX/SPX. You will also see "Client for Microsoft Networks". It's the same thing there also: check IPX/SPX and uncheck TCPIP.

Now look at tcpip on xp. Go to the tcpip protocol, choose advanced, go to wins and check "Disable NetBios over TCPIP". You are running netbios on ipx/spx.

It seems xp isn't as easy to setup as it is to use.

DrBob

Collapse -

XP PC's Do Not See 98 PC's

by qballrail In reply to XP PC's Do Not See 98 PC' ...

Since I am on Cablemodem I cannot disable NetBios over TCP/IP. I lose internet connectivity all together. However, your first suggestion to enable NetBios over IPX/SPX worked. My 98 PC's are now seen by XP and vice-versa. The rest of the settings you suggested were seemingly set by default. It's always the small things we seem to miss, isn't it? Thank you for your continued assistance, it proved to be successful.
JH

Collapse -

XP PC's Do Not See 98 PC's

by qballrail In reply to XP PC's Do Not See 98 PC' ...

This question was closed by the author

Back to Windows Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums