Question

Locked

XP Pro clean install now USB mouse/kbd won't "invalid data"

By rws_99 ·
Hi All, I am new to the group. I came here because I have given up on all my google searches and other resources. Hope someone here can help with arcane problem.

I upgraded a friend's home built computer. ASUS A8V Deluxe mobo. 4GB Corsair RAM. AMD 3500+.

I did a clean install of XP SP1 and dnl 62 patches from MS.

I thought I tested everything. I use a PS/2 mouse so I never tested for a USB mouse. I shipped the upgraded box to him, and now he gets an error every time Windows tries to install the USB mouse driver from "Found New Hardware". He gets message "Unable to install.... Invalid Data".

What I have done so far: 3/5/08

1. Installed drivers from ASUS site for A8V Deluxe: i.USB2 ? (although it was a flaky install and we were not so sure conflicting instructions in readme as well. ii.S3USB registry patch iii. VIA 4in1 drivers
2. Installed Microsoft USB for SP1 patch
3. Tested hardware USB ports ? tested with camera and USB cord. Worked OK. It is not the hardware prot.
4. Ran Found New Hardware wizard and it found the USB optical mouse but gave same error ?Invalid Data? and a driver code 28 when could not install driver.

5. Registry - set "allow" for USB "everyone"

I am going out of my mind with this one.

Help would surely be appreciated. Thanks in advance. Royce

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

BIOS

by mmauer In reply to XP Pro clean install now ...

Have you checked BIOS for allow key board mouse/keyboard. Also allow legacy USB

Depending on the BIOS there will be 1 to 3 setting regarding USB

Collapse -

Also after you check the BIOS and change whatever is required

by OH Smeg In reply to XP Pro clean install now ...

Apply SP2 it cures a lot of USB problems. USB on prior versions of XP was flaky at best and unworkable at worst.

Col

Collapse -

Thanks for your responses. I am still looking for the silver bullet

by rws_99 In reply to XP Pro clean install now ...

Thanks Guys,

Yes, I have checked the BIOS settings. There are a number of them that could affect the USB mouse. USB 1.1 config= 8 ports enabled, USB 2 controller= enabled, Legacy USB support=Auto, USB controller mode= full speed.

Regarding installing SP2, I am trying to avoid it, as it adds overhead to the system and my client is a multitasker and uses a lot of system resources. I am trying to keep Windows as small as possible.

Any other ideas? (I have a XP SP1 box of my own with modest system resources and I plugged in a USB mouse so I could observe first hand how windows behaves. XP "Found new" and "installed" without a hiccup.) When it works, it works seamlessly.

Any services that could be a problem?

I am still out on the cold here... I need any more ideas at all please. (Thanks to you who have given yours already)'

Regards,
Royce

Collapse -

Well SP2 did add USB 2 functionality to XP

by OH Smeg In reply to Thanks for your responses ...

XP SP1 and older would only natively support USB1.

Did you get any USB Drivers with the Mouse? Have you tried looking in Device Manager to see if all the Drivers are installed and up to date. Maybe updating the M'Board Chip Set Drivers and USB Drivers will cure this problem.

Then there is the Blatantly Obvious replace the USB Keyboard/Mouse with a PS2 one/set and forget about the problem. If it's working Well enough for the user as it is don't mess with it and alter the hardware to what works properly.

OH BTW how much of the RAM is Windows actually using?

All I can think of at the moment I'll post back if I think of anything else.

Cheers

Col

Collapse -

OK I installed SP2. Still no resolution. "Data is Invalid"

by rws_99 In reply to XP Pro clean install now ...

I also deleted all references to Mice and keyboards in the device manager and deleted all the USB references and let Windows rebuild them. The mouse/kbd I am trying to connect is a HID type and it is working on my other computer so I know the device is OK. Anymore ideas anybody? Thanks in advance. I spent three hours on the phone with my friend today. At this point I am almost ready to have him ship it back to me. If I had the box here I could at least try a lot of things rapidly. It is very tedious using somebody else's hands and feedback.

Ideas please!

Collapse -

Now here

by Jacky Howe In reply to XP Pro clean install now ...

is an interesting article.

http://www.observatory.org.nz/usbwebcam.html

Collapse -

USB Invalid data

by doug.h.rice In reply to XP Pro clean install now ...

I have also suffered all new USB devices getting the data is invalid message after plugging in a new USB device, like a mouse, memory stick or my new mobile phone.

The software was installed off the disk supplied for the mobile phone.

Using control pannel and system hardware managers, I got told that the device was not installed correctly.

Using RegEdit I found the USB device

e.g.[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_05e3&Pid_0660]


I found that the permissions did not allow any user to do annything.

I enabled permissions for all users, and my USB now works.

I also enabled permissions for the parents and pushed down to the siblings.

I do not really know what I should have enabled.

I do not know what caused the permissions to be corupted.

Doug

Collapse -

Bad driver in cache?

by rfoster55 In reply to USB Invalid data

I found this here and it worked for me:

http://www.techspot.com/vb/all/windows/t-1094-Installing-PCI-carddrivers-data-invalid-error.html

"
C:\WINDOWS\DRIVER CACHE\i386.

Back it up first, then delete everything in it.

Open Device Manager and Click Update Driver.

No more problem. :) :) :)
"

Good luck.

Bob

Collapse -

This fixed it

by leeutjie In reply to Bad driver in cache?

Solution. This fixed it... Wouldn't have believed it, if I hadn't tried it.

Collapse -

Well Done! This did it.

by mike In reply to Bad driver in cache?

Thanks to you I can now click again!

Back to Software Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums