Question

Locked

XP Pro SP3 Windows Firewall Advanced tab corrupted

By Healer ·
Tags: Off Topic
When I tried to open the Advanced tab on Windows Firewall I got the message "The network connection settings have become corrupted." I clicked Restore Defaults as advised but it didn't fix the problem.

I don't seem to have any problem with the network or the firewall except the Remote Desktop Connection can't connect as reported on http://techrepublic.com.com/5208-6230-0.html?forumID=101&threadID=314144&tag=nl.rCOMBINED

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try this

by Jacky Howe In reply to XP Pro SP3 Windows Firewa ...

Error "The network connection settings have become corrupted" when configuring Windows Firewall

http://www.winhelponline.com/articles/6/1/Error-The-network-connection-settings-have-become-corrupted-when-configuring-Windows-Firewall.html

Collapse -

No good!

by Healer In reply to Try this

It has made no difference. The service in questions had been set Automatic and started. I ran those commands on a command prompt and a message of success came back after each regsvr32 command. I have even restarted the computer and tried again. It was still the same.

Collapse -

Create a manual System Restore point

by Jacky Howe In reply to XP Pro SP3 Windows Firewa ...

Check these Registry setting against yours on the XP Pro System. If they are different right click on FirewallPolicy and select Export. Save it as preFWfix.reg.


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications\List]
"%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
"%windir%\\Network Diagnostic\\xpnetdiag.exe"="%windir%\\Network Diagnostic\\xpnetdiag.exe:*:Enabled:@xpsp3res.dll,-20000"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\GloballyOpenPorts]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"
"139:TCP"="139:TCP:*:Enabled:@xpsp2res.dll,-22004"
"445:TCP"="445:TCP:*:Enabled:@xpsp2res.dll,-22005"
"137:UDP"="137:UDP:*:Enabled:@xpsp2res.dll,-22001"
"138:UDP"="138:UDP:*:Enabled:@xpsp2res.dll,-22002"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile]
"EnableFirewall"=dword:00000001
"DoNotAllowExceptions"=dword:00000000
"DisableNotifications"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications\List]
"%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
"%windir%\\Network Diagnostic\\xpnetdiag.exe"="%windir%\\Network Diagnostic\\xpnetdiag.exe:*:Enabled:@xpsp3res.dll,-20000"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"
"139:TCP"="139:TCP:LocalSubNet:Enabled:@xpsp2res.dll,-22004"
"445:TCP"="445:TCP:LocalSubNet:Enabled:@xpsp2res.dll,-22005"
"137:UDP"="137:UDP:LocalSubNet:Enabled:@xpsp2res.dll,-22001"
"138:UDP"="138:UDP:LocalSubNet:Enabled:@xpsp2res.dll,-22002"


Copy the text below to NotePad and save it as Firewall.inf then right click on it and select Install. Log off and then log back on for it to take effect. Keep us posted.


[version]
Signature = "$Windows NT$"
DriverVer =07/01/2001,5.1.2600.2132
[DefaultInstall]
AddReg=ICF.AddReg.DomainProfile
AddReg=ICF.AddReg.StandardProfile
[ICF.AddReg.DomainProfile]
HKLM,"SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications\List","%windir%\system32\sessmgr.exe",0x00000000,"%windir%\system32\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"

[ICF.AddReg.StandardProfile]
HKLM,"SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications\List","%windir%\system32\sessmgr.exe",0x00000000,"%windir%\system32\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"

Collapse -

You may have to manipulate the text

by Jacky Howe In reply to Create a manual System Re ...

as these are all on one line.

HKLM,"SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications\List","%windir%\system32\sessmgr.exe",0x00000000,"%windir%\system32\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"

Collapse -

What is this?

by Healer In reply to You may have to manipulat ...

I don't know what this is. This is exactly the same as the last entry in the install file. Anyway I added to the end of the install file and tried again and it didn't make any difference.

Collapse -

There made no difference at all.

by Healer In reply to Create a manual System Re ...

I have checked according to the instructions. Below is the result. After installing the Firewall.inf I checked the registry again and there was no difference. The Windows Firewall Advanced tab still had the same problem Your install file did not seem to add back the missing entries.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications\List]
"%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
"%windir%\\Network Diagnostic\\xpnetdiag.exe"="%windir%\\Network Diagnostic\\xpnetdiag.exe:*:Enabled:@xpsp3res.dll,-20000"

missing:
"%windir%\\Network Diagnostic\\xpnetdiag.exe"="%windir%\\Network Diagnostic\\xpnetdiag.exe:*:Enabled:@xpsp3res.dll,-20000"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"
"139:TCP"="139:TCP:*:Enabled:@xpsp2res.dll,-22004"
"445:TCP"="445:TCP:*:Enabled:@xpsp2res.dll,-22005"
"137:UDP"="137:UDP:*:Enabled:@xpsp2res.dll,-22001"
"138:UDP"="138:UDP:*:Enabled:@xpsp2res.dll,-22002"

missing:
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications\List]
"%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
"%windir%\\Network Diagnostic\\xpnetdiag.exe"="%windir%\\Network Diagnostic\\xpnetdiag.exe:*:Enabled:@xpsp3res.dll,-20000"

missing:
"%windir%\\Network Diagnostic\\xpnetdiag.exe"="%windir%\\Network Diagnostic\\xpnetdiag.exe:*:Enabled:@xpsp3res.dll,-20000"

Collapse -

Sounds like something is

by Jacky Howe In reply to There made no difference ...

definately corrupted somewhere along the lines.

Open up yor Firewall settings in Control Panel and make sure that Remote Desktop is enabled under Exceptions.
Highlight Remote Desktop and select Edit and check that port 3389 is selected.

Open a command prompt and type netstat -a and check to see if port 3389 is enabled.

Collapse -

netstat -a shows no port 3389

by Healer In reply to Sounds like something is

As far as the firewall settings are concerned, they are all correct.

However, the netstat -a has no mention of port 3389. The results are as follows.

Active Connections

Proto Local Address Foreign Address State
TCP main:epmap main:0 LISTENING
TCP main:microsoft-ds main:0 LISTENING
TCP main:1025 main:0 LISTENING
TCP main:5152 main:0 LISTENING
TCP main:10080 main:0 LISTENING
TCP main:13128 main:0 LISTENING
TCP main:18080 main:0 LISTENING
TCP main:netbios-ssn main:0 LISTENING
UDP main:microsoft-ds *:*
UDP main:isakmp *:*
UDP main:4500 *:*
UDP main:ntp *:*
UDP main:1900 *:*
UDP main:ntp *:*
UDP main:netbios-ns *:*
UDP main:netbios-dgm *:*
UDP main:1900 *:*

Collapse -

OK

by Jacky Howe In reply to netstat -a shows no port ...

Open regedit32 and navigate to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts\List]

and [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\GloballyOpenPorts\List]


create a new string value by right clicking in the right hand pane. Name it 3389:TCP and give it this value: 3389:TCP:*:Enabled:@xpsp2res.dll,-22009

Or save this information to Notepad and save the files with an extension .reg and install it by right clicking and selecting merge.

1.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"

2.

Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"


It maybe time for a fresh install of the Operating system if a System Restore from your earliest point in time or reinstalling the Firewall doesn't fix it.

Collapse -

Good on you!

by Healer In reply to OK

I have tried to reinstall SP3. It didn't look successful as it didn't take long though it said all right. After the computer restarted, the Windows Firewall was completely missing. So I don't think there is any point to try what you just suggested. I agree that it is the time to reinstall the operating system.

Though you have not helped me solve the problem I appreciate a lot your painstaking advice. I did learn something. Thanks again.!

Back to After Hours Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums