General discussion

Locked

XP Pro Won't Share Internet Connection

By DouglasB ·
Running XP Pro SP2. One NIC for ISP input from cable modem using pref & secondary dns servers. Can connect to ISP ok. Second NIC for home network, but other computers can not see the "sharing" computer or get to the internet. I have tried different NIC's, uninstalled and reinstalled software and run/re-run the internet setup wizard, no luck. DHCP service is running. The second NIC has been assigned an IP and subnet. When I remove this IP/Subnet the other computers can "see" each other, but then there is no internet connection. I have repaired the winsock, still not fixed.

This conversation is currently closed to new comments.

16 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by dustyD In reply to XP Pro Won't Share Intern ...

Are you actually sharing the host's internet connection? Or just using its connectivity?
Do you have the network connections bridged? How are you connecting the 'other computers'? Through hub, switch, router?
You say DHCP is used for the ISP NIC? Are the other computers assigned good IP's and subnet to match the LAN NIC?
If you have tried using the Network Connection Wizard have you picked the correct connection to internet and lan; just try making sure all settings are correct without it.

Collapse -

by DouglasB In reply to

Poster rated this answer.

Collapse -

by statykserver In reply to XP Pro Won't Share Intern ...

Here are two useful articles to help you out.

http://www.practicallynetworked.com/sharing/xp_ics/

http://www.microsoft.com/windowsxp/using/networking/learnmore/ics.mspx

Once the nic that is attached to lan (other pcs) has the ip address make sure the others have the same range so they can see each other.

Collapse -

by DouglasB In reply to

Poster rated this answer.

Collapse -

by diskaus In reply to XP Pro Won't Share Intern ...

I am actually runniing a similar setup to what you are describing, if you have not done so already open network connections, locate your internet connection and right click and select properties, click on the advanced tab and check the box "Allow other network users to connect through this computer's internet connection"
The second box " Allow other network users to control or disable the shared internet connection" is optional.
Also make sure when you setup the network using the wizzard ensure that the other PCs are configured to connect to the internet through the host PC " This computer connects to the internet through a residential gateway or through any other computer on my network"
depending on the specs of the other PCs it may take a few minutes for the other PCs to connect to the Internet.

Hope that helps

Collapse -

by DouglasB In reply to

Poster rated this answer.

Collapse -

by DouglasB In reply to XP Pro Won't Share Intern ...

I'm sharing the connect to the ISP, and nothing is bridged. The correct cards are configured for the correct connections and the computers connect via a switch, but none of the other computers are being assigned IP's.

Collapse -

by jstafs In reply to XP Pro Won't Share Intern ...

Have you checked the settings on the switch? To ensure that the sec. card for the home network is working try connecting another PC directly to that card. By bypassing the switch you will rule out that the switch is/isn't working.

Collapse -

by DouglasB In reply to

Poster rated this answer.

Collapse -

by DouglasB In reply to XP Pro Won't Share Intern ...

I checked out DustyD's links, everything is configured correctly. Appears the problem is the clinet computers won't pull an IP address, that is why they can't connect to the Internet or see the other computers on the local network. What's the fix for this?

Back to Windows Forum
16 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums