Question

Locked

XP SP2 Sharing Error! You won't know this one!

By Dutchice ·
UPDATE:
5. System restore, among very first actions to take, unsuccessful.
4. In-place Windows repair, tried and no success.
3. Read "Logged in as Administrator." as: "Logged in with the Administrator in-built account."
2. Also please read the post titled "Original post", since it kind of starts shining light on the cause of the whole issue.
1. Please read post titled "Quick answer" on this same thread too.
---------------------------------------------------

Hi Tech's,

Hopefully someone has the answer to this one! Cause at the moment not even M$ has heard about this.

Platform: Windows XP PRO SP2
Logged in as Administrator.
Simple File Sharing: Disabled
Problem: Cannot share any folders.
Error I get: ?An error occurred while trying to share <folder name>. The Data is invalid. The shared resource was not created at this time.?
Things I have done so far without any success:
1. Stopped the ?Server? service and restarted again.
2. Uninstalled the ?Client for Microsoft Networks? client and the ?File and Printer Sharing for Microsoft Networks? service. Reboot. Installed both again. Reboot.
3. Looked for any event in the ?Application?, ?Security?, ?System?, etc. events. Found nothing recent at all.
4. Made a new folder on a different hard disk and tried to share it. But I get the same error.
5. Checked all ?Ownerships? and ?Permissions?. Everything OK, my user account is in full charge of everything.
6. Turned "Guest" account off and on again. No success either.

So far I have searched hours and hours on internet to find any posts about the problem, but there is nothing relevant. However I?ve encountered people talking about the error without finding a solution for it.

Microsoft?s KB does not even have anything related to such an error.

I could find in some forum in some language I don?t understand and it appears they are talking about programs such as Norton Ghost and Acronis TrueImage, I have recently installed both software to do a backup of my laptop but did nothing at all to my own PC with them. Just saved the laptop?s image on my hard disk.

Also I have recently installed and uninstalled after a week or two the latest WDS for WinXP add on, which I found not to be useful at all compared to XP?s native search engine.

So guys, where could we start digging you think? Cause this is turning to be my worst nightmare!

Cheers,

Mario

This conversation is currently closed to new comments.

126 total posts (Page 1 of 13)   01 | 02 | 03 | 04 | 05   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try looking at this

by The Scummy One In reply to XP SP2 Sharing Error! You ...

go to a command prompt and type
net share <enter>

Is IPC$ displayed? If not you cannot get a share created.

Collapse -

Affirmative.

by Dutchice In reply to Try looking at this

D$
ADMIN$
C$
IPC$
Are all in the list.

Collapse -

Have you tried re-installing

by The Scummy One In reply to Affirmative.

TCP/IP?

First, try this
netsh ip int reset resetlog.txt

If this does not work, you can try re-installing TCP/IP by deleting Winsock and Winsock 2 in the registry, and rebooting. It is not installed now and will allow you to install it.
In this link scroll down until you see Windows XP without Service Pack 2 instructions
http://support.microsoft.com/kb/811259

Collapse -

Reinstall Windows

by mlink In reply to Have you tried re-install ...

Have you tried reinstall windows?

Collapse -

XP Pro or Home?

by seanferd In reply to XP SP2 Sharing Error! You ...

XP Home: Open My Computer in Explorer. Tools > Folder Options > View > Advanced > disable 'USE SIMPLE SHARING(Recommended)' > Apply.

Collapse -

It sounds like

by The Scummy One In reply to XP Pro or Home?

you have seen this before. Me, I am just guessing.

Collapse -

Not that specific error

by seanferd In reply to It sounds like

but it might be a common cause, or at least a starting point. There was one question on TR where that finally turned out to be the solution in a lengthy thread, and I've seen it in other cases where assigning permissions didn't work. Simple sharing kinda kills aspects of GP and file properties... to keep it simple.

Collapse -

Updated original question

by Dutchice In reply to Not that specific error

Indeed, I forgot to mention in my question; 1. Win XP Pro
2. Simple File Sharing: Was already disabled

Collapse -

Also try this

by Jacky Howe In reply to XP SP2 Sharing Error! You ...

if seanferd's suggestion dosn't work.

Navigate to C:\WINDOWS\system32 and run Shrpubw.exe and see what happens.

If this dosn't work try and take Admin Control back.

http://blogs.msdn.com/astebner/archive/2006/09/04/739820.aspx

and if that dosn't work

Windows XP Problems if Your Administrator Profile Is Damaged

If the default Administrator profile becomes corrupted, reinstall Windows XP to correct this issue.

http://support.microsoft.com/kb/316434

Collapse -

Tried out

by Dutchice In reply to Also try this

Thanks for your tip.
The result of the Shrpubw.exe was as follows;
"The following folder could not be shared: <folder name>" and then, The share was not successful for these reasons: "The following error occurred while creating the share for Microsoft Windows clients: The data is invalid.".
About your second tip of resetting the Admin rigths; well I took a look at the whole procedure but it looks just a bit too soon to start modifying the registry. We still don't even know the cause of the error. I recommend you take a look at post titled "Original Post", where I mention more about the total picture. What I have a very strong feeling about is that somehow the physical file structure on the disks have been changed, causing windows to think the "Data is invalid" as the error itself says.

Cheers,
Mario

Back to Networks Forum
126 total posts (Page 1 of 13)   01 | 02 | 03 | 04 | 05   Next

Related Discussions

Related Forums