Question

Locked

XP SP3 & RDP Access

By ACGPHX ·
I placed a new system on the domain which was up to date running XP SP2. The end-user saw that SP3 was available via windows update and chose to install it. Now I cannot access the system, which is 125 miles away, via RDP. I'm driving to the site on Monday to resolve several things but I want to ensure that the matter is resolved when I leave. I was told that there was no option to remove SP3 via the control panel. Restoring the sytem isn't something I'd prefer to do since there are several business critical applicaiton which were loaded on the system after the installation of SP3.

Does anyone know of a sure fix or workaround that would ensure I will be able to access the system using RDP with SP3 resident on the workstation? I'd really like to avoid too many 250 mile round trips if I can help it.

thanks in advance

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You can try this

by Jacky Howe In reply to XP SP3 & RDP Access

XP SP3 causes a problem with accessing remote desktop through Internet Explorer as the ActiveX control gets disabled. To get around this, you can Enable the Add-On "Terminal Services ActiveX control" in Internet Explorer 7 - if you are unable to see this add-on listed, you have to delete the following registry keys:

HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0}

HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2)


http://mswhs.com/2008/05/20/remote-desktop-and-xp-sp3-workaround/

http://www.wegotserved.co.uk/2008/05/17/windows-xp-sp3-update-breaks-windows-home-server-remote-access/

Collapse -

Did this already

by ACGPHX In reply to You can try this

I found this solution via google and tried it without sucess. I also ensured the the necessary services were started.

The issue is my inability to use RDP to log into this workstation from another.

Collapse -

Another step

by Jacky Howe In reply to Did this already

http://support.microsoft.com/kb/951607


If this does not resolve the issue, you can re-register the mstscax.dll file. To do this, follow these steps:
Exit Internet Explorer.
Click Start, click Run, and the type or copy and paste the following text in the Open box, and click OK:
%windir%\system32\regsvr32 mstscax.dll
At the confirmation prompt, click OK.
Restart Internet Explorer, and try to connect to the remote computer or start the remote application.

Collapse -

lol

by ACGPHX In reply to Another step

I did this too. I tried so many things I lost track of what I did. It turned out to be the Video setting.

Collapse -

Very strange

by Jacky Howe In reply to lol

but I'm glad that you have it sorted out.

Collapse -

Soltuion

by ACGPHX In reply to XP SP3 & RDP Access

Oddly enough the problem turned ut to be related to video.

I added this to the two afflicted systems registry's

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
"SessionImageSize"=dword:00000020

and the matter was resolved. Something about SP3 limiting the video environment to the extent that it can't handle the size of an RDP session.

Go figure.
Thanks for all of the input.
Hope it helps.

Collapse -

It would be interesting to know

by Jacky Howe In reply to Soltuion

what the error message was for future reference.

Collapse -

Nothing of note

by ACGPHX In reply to It would be interesting t ...

There was no error message in the logs or on the screen. You simply couldn't RDP into them After waiting a minutte or so you would get the standard MS connection timed out or unavailable message. Damn weird scenario considering SP3 was supposed to be the consolidation patch.

Collapse -

This was a response from one of the members

by Jacky Howe In reply to Nothing of note

but the connection was dimmed. As there was no reference to it I didn't post it as a fix. Turned out to be the fix anyway.

RAS starts and goes DIM Update the Video Drivers and try this Registry Hack


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
"SessionImageSize"=dword:00000020

Collapse -

yep

by ACGPHX In reply to This was a response from ...

This was the resolution on those two machines..thanks

Back to Windows Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums