Question

Locked

XP SP3 update failure - now my browser can't connect!

By davidsaintamour ·
I allowed my IBM T42 laptop to update from XP SP2 to SP3. During file copy, some music file can't copy, and the whole process fails, then rolls back. EXCEPT... I can't access the internet with the majority of my programs, like IE, Firefox, thunderbird, AVG8free, BOINC,etc. Strangely, I can ping my server, I can use my VPN connection to access my work network and remote desktop to my work computer. Thus, the connection is there, but somehow is deformed. Can anyone suggest anything short of a reinstall?
I've tried to redo the update (failed). I've tried to download the update file from MS, twice, but my system says the file is corrupt. Help!

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try logging in as....

by ThumbsUp2 In reply to XP SP3 update failure - n ...

THE Administrator, not just an account with administrative rights.

You can log in as THE Administrator by pressing CTRL+ALT+DEL two times at the logon screen, then type the word Administrator for the user name and supply the appropriate password.

Once logged in as THE Administrator, try your update again.

Collapse -

restore

by clarkd038 In reply to Try logging in as....

You should have system restore.
Go to the start menu, and accessories then click on system, system restore. Select the last restore point.

Give that try if not delete the installer for SP3, and go to programs and delete the update.

good luck

Collapse -

thank you

by davidsaintamour In reply to restore

My thanks to clarkd038 and thumbsup2 for their advice. I was able to restore my system to the pre-upgrade state and restore my internet access.

My attempts to upgrade to SP3 still fail, and I think I'm going to give up and just keep SP2. For some reason there is a file that just won't install (something like beethoven.wma, I don't remember the exact file name) and the upgrade installer just won't skip over it. Like I care about the stupid example sound tracks!

Anyway....

Thanks again!! to everyone who responded to my pleas for help, it is much appreciated!

Collapse -

Well as the Internet is working because you can

by OH Smeg In reply to XP SP3 update failure - n ...

Connect through the VPN it sounds like the Firewall is blocking the other applications.

You can try disabling the Firewall and see if it works correctly now or you may like to try the Method 3 Fix listed here

http://tinyurl.com/5nacly

This seems to cure all of the SP3 problems well the few that I have run into it does at least.

Method 3: Reset the registry and the file permissions
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows

Important This method is intended for advanced computer users. If you are not comfortable with advanced workarounds, you might want to ask someone for help, or you might want to contact Microsoft Customer Support Services. To contact Microsoft Customer Support Services, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)
1. Download and then install the Subinacl.exe file. To do this, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en)
2. Start Notepad.
3. Copy and then paste the following text into Notepad.
cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure. However, they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.
4. Save this Notepad file as Reset.cmd.
5. Double-click the Reset.cmd file to run the script.

Note This script file may take a long time to run. Additionally, you have to run this script as an administrator.
6. Install Windows XP SP3.

Back to the top

MORE INFORMATION
How to verify that the registry update has failed
1. Open the Svcpack.log file. By default, this file is located in the C:\Windows folder. To open the Svcpack.log file, click Start, click Run, type %windir%\svcpack.log, and then click OK.
2. On the Edit menu, click Find.
3. In the Find what box, type DoRegistryUpdates failed, and then click Find Next.
A "DoRegistryUpdates failed" error message in the file indicates that an issue is preventing the registry update. The error message will resemble the following error message:
xxxx.xxx: DoInstallation:DoRegistryUpdates failed.
xxxx.xxx: Access is denied.
xxxx.xxx: Message displayed to the user: Access is denied.
Note In this message, xxxx.xxx represents the time stamp of each entry.


Hope that is of some use.

Col

Collapse -

If you have an older version of ZoneAlarm installed ...

by OldER Mycroft In reply to XP SP3 update failure - n ...

This might be the cause.

There was a problem recently that ZoneAlarm objected to a piece of the M$ Update code, resulting in blocking all browser access to the internet.

A new build of ZoneAlarm was released a couple of days later but if you haven't downloaded and installed the latest build, that might be the cause.

In the meantime you can release your browser back onto the internet by reducing the security level within ZoneAlarm by reducing the level in 'Internet Zone Security' [Firewall Section] from High to Medium.

<Typo>

Collapse -

Or you could . .

by Kenone In reply to If you have an older vers ...

Just uninstall kb951748

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums