General discussion

Locked

XP won't install usb mouse

By bpcan55 ·
I have 2 Acer Aspire 3500 notebooks running XP Home. I decided to add a mouse to the machines. The first machine the mouse installed without a problem (as expected). On the 2nd machine, the mouse is recognised as a USB device, but then appears in Device Manager as an unknown device. Tried uninstalling and re-installing. Tried dis-connecting and reconnecting without success. I tried a different mouse - still no luck. The other mouse worked fine on the other machine. I know the USB ports are OK. I have used flash drives and a numeric keypad without a problem.

Usually the properties of the "unknown device" says the driver is not installed, or during the process it may say that there is a problem with a line in the INF file. Which INF file would that be? Is that really the problem?

Any suggestions?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Mouse

by zlitocook In reply to XP won't install usb mous ...

Was this on a docking station or a direct connect to the laptop? I have seen docking stations that would not see USB ports, try connecting direct to the laptop. You can remove the USB from the device manager and reboot to let it reinstall. Then try to reconnect the device.

Collapse -

Not using docking station

by bpcan55 In reply to Mouse

We are talking direct connection and I have tried all 3 ports on the notebook. I have uninstalled and re-installed many times.

Collapse -

Disregard My reply

by wiseone In reply to Not using docking station

oops Missed part about you trying mouse on both machines......

Collapse -

drivers for the usb controller?

by messwithdeagle In reply to Disregard My reply

you said you had working usb devices currently? drivers?

Collapse -

Other usb devices OK

by bpcan55 In reply to drivers for the usb contr ...

Yes, flash drive works fine. Just the mouse will not install (2 different mice which work fine on the other machine).

Collapse -

Same Prob

by Alyssa_Nicholson In reply to Other usb devices OK

I am having the exact same problem, you are not alone in your mouse troubles. I've even e-mailed Logitech many times and noone has gotten back to me. Are they different makes of mouse or are you sticking with just one?

Collapse -

same prob too

by toshni In reply to Same Prob

I am having exactly the same prob, with an optical labtec mouse and an acer aspire 5100. Properties of the unknown device say that drivers are not installed.

Collapse -

My Solution To Same Problem

by Steveo-616 In reply to XP won't install usb mous ...

I came across the same problem when i bought a new Microsoft usb optical mouse for my desktop running on windows XP 32-bit, It would work on my laptop installing the software automatically like my others (it came with no software disc), but whenever i tried to on my desktop it would come up with "Unknown Device" in my device properties and it would also say error when trying to install, the infrared would show under the mouse but it wouldnt move and i know my ports are fine. I had also tried removing it, restarting it, trying diff ports etc. So i done some netsurfing and found alot of other ppl with the same problem and tried all their ideas everything from BIOS changes etc with no luck.

The Simple Solution: I ended up going to the Microsoft site itself and found you can download the software for your mouse, keyboard whatever, and from the software d/l's i chose my model and downloaded the software for my operating system (XP 32BIT) ran it, and now it works perfectly. I have no idea why it just couldnt install automatically like my laptop does, but i hope this helps someone with the same problem.

Back to Windows Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums