General discussion

Locked

XPpro forces dialup when accessing NW

By jenniferN ·
XP Pro PC on small NW with W2k server.

Whenever the user accesses files & folders on the Server, it invokes dial up (on the central modem on the server).

Other than a trojan, (which I doubt, since it has done this since it was initially set up) what else might be prompting dialup in this circumstance? I'm running out of ideas.

Thanks

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

XPpro forces dialup when accessing NW

by TheChas In reply to XPpro forces dialup when ...

Check the connection settings in IE.

You may need to set it to always dial my default connection.

Why?

IE and Windows Explorer are VERY intertwined.
Whenever you access a file, you are using Windows Explorer, and thus IE to browse to the file.

You may also need to change how the server handles dialing the connection.

Chas

Collapse -

XPpro forces dialup when accessing NW

by jenniferN In reply to XPpro forces dialup when ...

Poster rated this answer

Collapse -

XPpro forces dialup when accessing NW

by jenniferN In reply to XPpro forces dialup when ...

Poster rated this answer

Collapse -

XPpro forces dialup when accessing NW

by jenniferN In reply to XPpro forces dialup when ...

I've been out of the office, so couldn't check til today, but of course, the IE connection options (eg always /never dial default connection) are greyed out... because the dialup is handled through a proxy server. The LAN proxy server settings on this machine are correct, and the problem can't be with the proxy, as none of the other client PCs have this problem. ANY MORE IDEAS?

Collapse -

XPpro forces dialup when accessing NW

by jenniferN In reply to XPpro forces dialup when ...

Point value changed by question poster.

Collapse -

XPpro forces dialup when accessing NW

by Nap Jones In reply to XPpro forces dialup when ...

This may help. I ran across this info on one of my other forums as one of my clients was having a simular issue:
Auto-Dialing Issues

Check your settings here: Network Connections/Advanced/Dial-Up Preferences/Enable Auto-Dial by Location/Uncheck all locations.

To view the list of names and addresses recorded by AutoDial, type the following command at a command prompt:
rasautou -s

To delete a name or address entry from the list: Start/Run/Regedit

HKEY_CURRENT_USER\Software\Microsoft\RAS Autodial\Addresses

You can delete any TCP/IP addresses that you see under this key. Note that AutoDial can use IP addresses, DNS fully qualified domain names (FQDN), and NetBIOS names.

How to Use the Rasdiag.exe Support Tool in Windows XP


Modify the Internet Auto-Dial Settings

Windows has the option to automatically dial your Internet Service Provider (ISP) to establish an Internet connection. This option can be controlled using this tweak.

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
Value Name: EnableAutodial
Data Type: REG_BINARY (Binary Value)
Value Data: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Create a new binary value named "EnableAutodial", and set the new value to equal "01 00 00 00" to enable autodial or "00 00 00 00" to disable it.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE

Collapse -

XPpro forces dialup when accessing NW

by jenniferN In reply to XPpro forces dialup when ...

Poster rated this answer

Collapse -

XPpro forces dialup when accessing NW

by D-W In reply to XPpro forces dialup when ...

Can't remember exactly where the setting is (I think it is just in the dial-up settings for the connection with ICS enabled), but if ICS is set up, there are options to connect to the internet when a client requests, or something along those lines.Disabling this will stop the dial-up.

Collapse -

XPpro forces dialup when accessing NW

by jenniferN In reply to XPpro forces dialup when ...

Fortunately this is not an ICS workgroup setup. It is a server sharing dialup access through a proxy. The client does request internet connection and that works just fine, as it should, on request. The problem is that the system dials up when they request local network disk access, ie simply opening up mapped drives and folders on the LAN. I am sure the proxy is not redirecting these requests, as it occurs from one workstation only, and all workstations share the proxy server.

Collapse -

XPpro forces dialup when accessing NW

by jenniferN In reply to XPpro forces dialup when ...

to Nap Jones
RAS service is not running on either the workstation or the server, and the rasautou -s command lists 0 autodial addresses on the xp machine.

Before I try the registry change you have suggested, I have a couple of questions:
1. Does this setting manage the XP machines dial up request to the proxy server?
2. the key on this machine doesn't exactly match your info, data type is REG_DWORD, and it would appear from the current data value (0x00000000 (0)) that it is currenty disabled anyway??
3. the current settings are identical to another client machine which is not attempting to dial to access LAN resources. so do you really think this is the way to go?

I suspect this is not an internet connection issue. I'm more inclined to think it is some kind of DNS issue, where the Client thinks it needs to go out on the net to find local resources.

Back to Windows Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums