Access network shares without providing password

By MNE ·
Heres the situation, Server 2003 machine running as a terminal server and XPPro machine running as file server. I have set up a shared folder on the XP machine to store all TS users data. When i try to set up the profiles in the users properties on the server2k3 machine it says cannot find the network resource. From the server2k3 machine i have opened the run dialog and typed \\xpmachine at which point a login dialog appears, if i login using credentials from the xp machine no problems. I need to be able to access these network sharres without providing credentials. I have gone to gpedit on the xpmachine and changed Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options > Accounts: Limit local account use of blank passwords to console login only to disabled but it has had no effect.
There is only a few TS users so i could set up the accounts manually on the xp machine however any changes in passwords will cause problems again.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

simple file sharing

by yovev In reply to Access network shares wit ...

I suppose you are not using AD.
On the XP machine go to control panel - folder options - the VIEW tab. In the bottom check "Use simple file sharing (Recommended)". Apply and to be sure it will take effect restart the PC.
Have in mind that if My documents is set private for any user on the XP machine and you try to share something inside it you will not have any success.

Collapse -

I wish

by MNE In reply to simple file sharing

I wish it was that simple, sorry i forgot to mention that i had already tried that, both with Simple File Sharing enabled and disabled.

I went back and tried Simple File Sharing just in case i missed something, the error i get is Logon failure: the user has not been granted the requested logon type at this computer.

Collapse -

ok then

by yovev In reply to I wish

"Logon failure: the user has not been granted the requested logon type at this computer"
You get this error when trying to access the machine with the shared folders?

On the xp machine you have to remove the password for the user who has made the shares or enable the guest account. If the machine has SP3 installed it automaticaly disables it. (Enable it from Computer Management - Local Users and Groups).
And make sure the folders are not shared from the Administrator's account (this is to isolate other possible causes).

Collapse -


by MNE In reply to ok then

The shares were shared from and admin account, that could have had an effect on it. The company needed it up and running so I had to work around the issue. Luckily for me there was only 4 TS users, so i set up those account on the xp machine as well, assigned a password and then connected each of them in turn, entering the password and checking the remember password option. Obviously not an ideal solution for a large established company but in my case it will do. Cheers for the ideas.

Related Discussions

Related Forums