Question

Locked

Cisco 1811- no configured DNS servers are routable through...

By charleswright99 ·
Greetings,
I have configured an 1811 to connect to Internet (thanks to articles on here), but I am unable to get to the hostname unless I specify the DNS server info on my local machines.
I have yet to turn on DHCP on the router and using SDM to configure. I run the test on the WAN interface without error. The test connection on the LAN interface has the DNS error for the "Checking exit interface.." I can get to host names on the Internet only if I have the external DNS servers (from ISP) statically configured on the local machines.
Please help me understand what entry I am missing and why I need it. Do I need to make an entry for DNS to pass-through?
Thank you very much for your valuable assistance.

Here is the running config:

Current configuration : 3705 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname INDY-ROUTER
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
enable secret 5 $1$Xt4C$iJ0H76aQA1vJWSY/.X02u.
enable password pl4$maisbetter!
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2359057039
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2359057039
revocation-check none
rsakeypair TP-self-signed-2359057039
!
!
crypto pki certificate chain TP-self-signed-2359057039
certificate self-signed 01
30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32333539 30353730 3339301E 170D3039 30383132 31393438
33305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 33353930
35373033 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100E76F 0C81667A BB1FE791 D32B0FFC 4362F5E9 278D2E08 32F8808B 2B731B2F
0FA56D77 2DD4EBE1 E5A195DB A7DA2909 583BA568 CE2C6B39 AEB84C58 ECA38F83
59D2ABDC A09E10 295BEE06 C7DF82F8 D368EF32 32AFDBDA 99C2DE86 9FBF151A
99896DC9 C63C40 1B8DCE98 2F3FF029 D3C2E2F1 AC3AD1B4 F2C38BEF 477E07DA
61A10203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603
551D1104 0F300D82 0B494E44 592D524F 55544552 301F0603 551D2304 18301680
140029C7 BB7A511F 6CBB78EE 8940034F 90679FE3 3E301D06 03551D0E 04160414
0029C7BB 7A511F6C BB78EE89 40034F90 679FE33E 300D0609 2A864886 F70D0101
04050003 81810062 41AB7893 ACA54C44 096508AC 975695D5 F0ED91D5 020AB12F
64446CC2 8938ACCE 707BCE1E 88B17817 4FC90FD8 C857D104 556E8467 D1356DDA
D3ABBFEB B8871096 97433E03 40B111A2 5E7FEDEE 9E4FFA04 B0DCA11B 6C5642A7
31FFA451 823DC309 98D94244 F8377156 75EF1934 E70917F6 3AD81468 64EABE41
878749F4 C4D99E
quit
dot11 syslog
ip source-route
!
!
!
ip cef
ip name-server 205.196.176.90
ip name-server 72.20.133.20
no ipv6 cef
!
multilink bundle-name authenticated
!
!
username cadmin privilege 15 password 0 cima
!
!
archive
log config
hidekeys
!
!
interface FastEthernet0
description WAN interface to Internet$ETH-WAN$
ip address 66.60.xxx.xxx 255.255.255.224
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
description LAN interface to Local$ETH-LAN$
ip address 10.1.61.1 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
half-duplex
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
shutdown
!
interface FastEthernet5
shutdown
!
interface FastEthernet6
shutdown
!
interface FastEthernet7
shutdown
!
interface FastEthernet8
shutdown
!
interface FastEthernet9
shutdown
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio1
no ip address
shutdown
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
shutdown
!
interface Async1
no ip address
encapsulation slip
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0
ip http server
ip http authentication local
ip http secure-server
!
!
ip nat pool mypool 66.60.xxx.xxx 66.60.229.53 netmask 255.255.255.224
ip nat inside source list 1 pool mypool overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
!
!
control-plane
!
!
line con 0
line 1
modem InOut
stopbits 1
flowcontrol hardware
line aux 0
line vty 0 4
password cima
login local
transport input telnet ssh
!
end

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

you do not want to allow DNS passthrough

by CG IT In reply to Cisco 1811- no configured ...

not sure what your saying is the problem. If you can browse web sites using static addresses then there isn't a problem.

Collapse -

Are you wanting to use the router as a DNS proxy

by NetMan1958 In reply to Cisco 1811- no configured ...

If so, enter these commands:
conf t
ip dns server
Then on each workstation specify 10.1.61.1 as the DNS server or go ahead and configure DHCP to hand it out. Here is a link to a good article on this:
http://www.nil.com/ipcorner/RouterDNS

If that's not what you are trying to do, then maybe you can explain it in more detail.

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums