Question

Locked

Cisco 871 and P2P torrent = crash?

By ss9940 ·
Hi all!

I have a problem with my cisco 871 (non-wireless) router. The tiny thing works like a charm UNTIL i use a torrent client inside my LAN. After using it for a while, memory errors start to pop up in the log, then the router dies (until you plug it out/in again). Can anyone suggest what to do? It isn't the nicest thing to loose the connection in the company because someone is using torrents... I'll post the config and an example of the errors i get later!

Thanx!

Alex

Here's the running config:

Building configuration...

Current configuration : 8506 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname router
!
boot-start-marker
boot system flash:/c870-advsecurityk9-mz.124-24.T.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 51200
logging console critical
enable secret 5 $1$mss1$A9ncfSMCEXKqfpYEu/nqJ.
!
no aaa new-model
clock timezone PCTime 1
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-3574414699
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3574414699
revocation-check none
rsakeypair TP-self-signed-3574414699
!
!
crypto pki certificate chain TP-self-signed-3574414699
certificate self-signed 01
30820246 308201AF A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33353734 34313436 3939301E 170D3130 30323038 31303535
34365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 35373434
31343639 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100A678 9C1ED6A8 E9AC44FF BAA79EDF DD88E9C9 56072168 1973654A 5304C5D9
37AC7091 86731EF3 6E4CC991 A22F3B2B 26F0BB5A 3FC2785F 77D3456D 58A63260
ABF2C18E 5660B04B 251C4786 AA9533E5 1FDC7357 7857821D 6DC2D08C 76409380
11BA9634 5FD22113 D244EF73 6908074B CB7598F0 9469861B 297F9CB6 AB61C440
D7F90203 010001A3 6E306C30 0F060355 1D130101 FF040530 030101FF 30190603
551D1104 12301082 0E726F75 7465722E 7069736B 2E736930 1F060355 1D230418
30168014 A551D511 9E404B1B E6A3D456 EC2DE3EE F1198A13 301D0603 551D0E04
160414A5 51D5119E 404B1BE6 A3D456EC 2DE3EEF1 198A1330 0D06092A 864886F7
0D010104 05000381 810018E1 3B184C1E 6502E5EE 740FD65D 74F11A84 67C1C537
BC147EBB 931EE684 085B1D0D FBD288FB AFB929A4 F260796C 752CE66B 046DAF24
EEEBF913 A3FF65CB 7E146A1F 60F669E6 5A2D19F1 20978222 17B2D93B 79910A97
D1D7DB39 E8BC07E0 3B5FC62A D5A65E81 52EAD179 76681D4C EE356EC2 482189E3
E38087F5 A1C9830F F32E
quit
dot11 syslog
no ip source-route
ip dhcp excluded-address 192.168.0.1 192.168.0.2
ip dhcp excluded-address 192.168.0.1 192.168.0.49
ip dhcp excluded-address 192.168.0.100 192.168.0.102
ip dhcp excluded-address 192.168.0.200
!
ip dhcp pool sdm-pool1
import all
network 192.168.0.0 255.255.255.0
dns-server 192.168.0.2 84.255.209.77
default-router 192.168.0.1
!
!
ip cef
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 netshow
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
no ip bootp server
ip domain name pisk.si
ip name-server 192.168.0.2
ip name-server 84.255.209.77
!
!
!
!
username router privilege 15 secret 5 $1$yXWe$K2AUKIjlJv.A1z3i9mXLK/
!
!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
ip rcmd rcp-enable
!
!
!
interface FastEthernet0
no cdp enable
!
interface FastEthernet1
no cdp enable
!
interface FastEthernet2
no cdp enable
!
interface FastEthernet3
no cdp enable
!
interface FastEthernet4
description $FW_OUTSIDE$$ES_WAN$
ip address 84.255.242.194 255.255.192.0
ip access-group 101 in
ip verify unicast reverse-path
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip inspect DEFAULT100 out
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
snmp trap ip verify drop-rate
no cdp enable
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.0.1 255.255.255.0
ip access-group 100 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet4
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static udp 192.168.0.15 4672 interface FastEthernet4 4672
ip nat inside source static tcp 192.168.0.15 4662 interface FastEthernet4 4662
ip nat inside source static tcp 192.168.0.2 8080 interface FastEthernet4 8080
ip nat inside source static tcp 192.168.0.200 80 interface FastEthernet4 180
ip nat inside source static tcp 192.168.0.200 23 interface FastEthernet4 123
ip nat inside source static tcp 192.168.0.15 3389 interface FastEthernet4 666
ip nat inside source static tcp 192.168.0.15 15919 interface FastEthernet4 15919
ip nat inside source static tcp 192.168.0.10 3389 interface FastEthernet4 6010
ip nat inside source static tcp 192.168.0.13 3389 interface FastEthernet4 6013
ip nat inside source static tcp 192.168.0.12 3389 interface FastEthernet4 6012
ip nat inside source static tcp 192.168.0.11 3389 interface FastEthernet4 6011
ip nat inside source static tcp 192.168.0.2 3389 interface FastEthernet4 3389
ip nat inside source static udp 192.168.0.2 53 interface FastEthernet4 53
ip nat inside source static tcp 192.168.0.2 53 interface FastEthernet4 53
ip nat inside source static tcp 192.168.0.2 1723 interface FastEthernet4 1723
ip nat inside source static tcp 192.168.0.2 47 interface FastEthernet4 47
ip nat inside source static tcp 192.168.0.2 1433 interface FastEthernet4 1433
ip nat inside source static tcp 192.168.0.2 1226 interface FastEthernet4 1226
ip nat inside source static tcp 192.168.0.2 1225 interface FastEthernet4 1225
ip nat inside source static tcp 192.168.0.2 21 interface FastEthernet4 21
ip nat inside source static tcp 192.168.0.2 110 interface FastEthernet4 110
ip nat inside source static tcp 192.168.0.2 25 interface FastEthernet4 25
ip nat inside source static tcp 192.168.0.2 80 interface FastEthernet4 80
ip nat inside source static tcp 192.168.0.15 3724 interface FastEthernet4 3724
ip nat inside source static tcp 192.168.0.15 6112 interface FastEthernet4 6112
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 100 remark auto generated by Cisco SDM Express firewall configuratio
n
access-list 100 remark SDM_ACL Category=1
access-list 100 deny ip 84.255.192.0 0.0.63.255 any
access-list 100 deny ip host 255.255.255.255 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 permit tcp any any eq smtp
access-list 101 permit tcp any any eq pop3
access-list 101 permit tcp any any eq ftp
access-list 101 permit tcp any any eq www
access-list 101 permit tcp any any eq 3389
access-list 101 permit tcp any any eq 1225
access-list 101 permit tcp any any eq 1226
access-list 101 permit tcp any any eq telnet
access-list 101 permit tcp any any eq 1433
access-list 101 permit tcp any any eq 47
access-list 101 permit tcp any any eq 1723
access-list 101 permit tcp any any eq domain
access-list 101 permit udp any any eq domain
access-list 101 permit esp any any
access-list 101 permit tcp any any eq 180
access-list 101 permit tcp any any eq 123
access-list 101 permit tcp any any eq 6010
access-list 101 permit tcp any any eq 6011
access-list 101 permit tcp any any eq 6012
access-list 101 permit tcp any any eq 6013
access-list 101 permit tcp any any eq 666
access-list 101 permit tcp any any eq 15919
access-list 101 permit gre any any
access-list 101 permit tcp any any eq 8080
access-list 101 permit tcp any any eq 3724
access-list 101 permit tcp any any eq 6112
access-list 101 permit tcp any any eq 4662
access-list 101 permit udp any any eq 4672
no cdp run

!
!
!
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums