General discussion

Locked

Cisco VPN 5 & Cisco ASA 5505 - No Internet

By jrenfro ·
I used the ASDM wizard to setup the VPN settings and can get to resources on the network with VPN but no internet access. I have checked the Allow Local Access on the client but I know that is overriden by the ASA unless it is allowed there. Problem is I do not know the commands to enter to get this to work and thought I did it during the wizard. Any help?

ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.x 255.255.255.240
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list out-in extended permit icmp any any
access-list out-in extended permit tcp any interface outside eq 3389
access-list out-in extended permit tcp any interface outside eq https
access-list out-in extended permit tcp any interface outside eq www
access-list out-in extended permit tcp any interface outside eq smtp
access-list out-in extended permit tcp any interface outside eq pop3
access-list out-in extended permit tcp any interface outside eq 3390
access-list RemoteAccess1_splitTunnelAcl standard permit any
access-list inside_nat0_outbound extended permit ip any 192.168.2.192

255.255.255.192
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool RemoteAccess 192.168.2.210-192.168.2.230 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface https 192.168.2.4 https netmask

255.255.255.255
static (inside,outside) tcp interface pop3 192.168.2.4 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.2.3 3389 netmask 255.255.255.255
static (inside,outside) tcp interface smtp 192.168.2.100 smtp netmask

255.255.255.255
static (inside,outside) tcp interface www 192.168.2.4 www netmask 255.255.255.255
static (inside,outside) tcp interface 3390 192.168.2.3 3390 netmask 255.255.255.255
access-group out-in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
aaa authentication http console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal 20
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

group-policy RemoteAccess1 internal
group-policy RemoteAccess1 attributes
dns-server value 192.168.2.4
vpn-tunnel-protocol IPSec
password-storage enable
group-lock value RemoteAccess1
ipsec-udp enable
ipsec-udp-port 10000
split-tunnel-policy tunnelspecified
split-tunnel-network-list value RemoteAccess1_splitTunnelAcl
default-domain value aarc.local
address-pools value RemoteAccess
group-policy RemoteAccess internal
group-policy RemoteAccess attributes
dns-server value 192.168.2.4
vpn-idle-timeout 60
vpn-session-timeout none
vpn-tunnel-protocol IPSec
ipsec-udp enable
ipsec-udp-port 10000
split-tunnel-policy tunnelspecified
split-tunnel-network-list value RemoteAccess1_splitTunnelAcl
username schopra password B977nP8WGqTnsGjR encrypted privilege 0
username schopra attributes
vpn-group-policy RemoteAccess1
vpn-idle-timeout 60
vpn-session-timeout none
password-storage enable
group-lock value RemoteAccess1
username gciavarella password dXw6UflUMTlVOPsb encrypted privilege 0
username gciavarella attributes
vpn-group-policy RemoteAccess1
vpn-idle-timeout 60
vpn-session-timeout none
password-storage enable
group-lock value RemoteAccess1
username athompson password ftCLmBTpvXOB0J.3 encrypted privilege 0
username athompson attributes
vpn-group-policy RemoteAccess1
vpn-idle-timeout 60
vpn-session-timeout none
password-storage enable
group-lock value RemoteAccess1
username vswarup password G9KlEqaM2m0L6PeK encrypted privilege 0
username vswarup attributes
vpn-group-policy RemoteAccess1
vpn-idle-timeout 60
vpn-session-timeout none
password-storage enable
group-lock value RemoteAccess1
username labreu password 91rgiMnnX.9dMr4d encrypted privilege 0
username labreu attributes
vpn-group-policy RemoteAccess1
vpn-idle-timeout 60
vpn-session-timeout none
password-storage enable
group-lock value RemoteAccess1
username jdistefano password sNRx0yqOoHIp8lZE encrypted privilege 0
username jdistefano attributes
vpn-group-policy RemoteAccess1
vpn-idle-timeout 60
vpn-session-timeout none
password-storage enable
group-lock value RemoteAccess1
tunnel-group RemoteAccess type ipsec-ra
tunnel-group RemoteAccess general-attributes
default-group-policy RemoteAccess
tunnel-group RemoteAccess ipsec-attributes
pre-shared-key *
tunnel-group RemoteAccess1 type ipsec-ra
tunnel-group RemoteAccess1 general-attributes
address-pool RemoteAccess
default-group-policy RemoteAccess1
tunnel-group RemoteAccess1 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map global_policy
class inspection_default
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:cc0e2bb777725e7d5ed8387837cb5840
: end

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

A couple of questions

by NetMan1958 In reply to Cisco VPN 5 & Cisco ASA 5 ...

(1) Which of the defined usernames are you connecting with
(2) Is the dns-server 192.168.2.4 able to resolve non-local names

Collapse -

A couple of answers

by jrenfro In reply to A couple of questions

(1) schopra, gciavarella, athompson, vswarup, labreu, jdistefano
(2) It is a Microsoft Server 2003 machine and it can resolve internally. Setup the forwarders in DNS to go external for anything it doesn't know.

Hope this helps and thanks for the help!

Collapse -

A few things to try

by NetMan1958 In reply to A couple of answers

you may already have done this but if you haven't, connect to the vpn and then open a command prompt. Run "ipconfig /flushdns" then ping something on the internet by name, such as www.yahoo.com. See if it resolves to an ip address. If it does resolve ok, try a tracert from the command prompt: "tracert -d www.yahoo.com". Post back with the results from those tests.

Collapse -

Issues

by jrenfro In reply to A few things to try

I can't seem to get outside of the internal network but thought I had allowed local lan access on the ASA and client. I noticed that once the VPN is connected using the route print command shows that the new default gateway is the VPN connection so it is tunnelling everything through it. I think I am going to try to manually set the interface metrics per network connection to alleviate this issue. I will also try what you posted and post results if I can find another machine to test it on. Thanks!

Collapse -

On second look

by NetMan1958 In reply to Issues

at your config, I think I spotted something. Try changing this:
access-list RemoteAccess1_splitTunnelAcl standard permit any
To:
access-list RemoteAccess1_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0

If it still doesn't work after that change, I have seen this make a difference. Try changing:
ip local pool RemoteAccess 192.168.2.210-192.168.2.230 mask 255.255.255.0
to:
ip local pool RemoteAccess 172.16.2.1-172.16.2.20 mask 255.255.255.0
and this:
access-list inside_nat0_outbound extended permit ip any 192.168.2.192
to:
access-list inside_nat0_outbound extended permit ip 192.168.2.0 255.255.255.0 172.16.2.0 255.255.255.0

Let me know how it goes.

Collapse -

Solved

by jrenfro In reply to On second look

access-list RemoteAccess1_splitTunnelAcl standard permit any
To:
access-list RemoteAccess1_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0

That did it! I really don't get the logic behind one not work over the other but it works so I don't care. Thanks!

Related Discussions

Related Forums