General discussion

Locked

Citrix, 2003 Servers and Pervasive SQL Database

By ktucker ·
Hopefully the wealth of knowledge from the techrepublic group can help me with this problem. I am currently running 2003 Server (specs are moot on all server listed ... all are more than enough power (overkill even (dual xeons, 2 - 4 gigs of memory etc.) with a Pervasive SQL Database powering one of our applications. On that same network segment I have two Citrix servers also running on Windows 2003 in a farm setup (again Xeons with minimum 2 gig of memory). The Dbase server is my DC and running active directory ... the citrix machines are simple member servers on the network within the domain. DNS and DHCP is handled through the DC. All other workstations on the network (windows 2000 and windows XP) attach to the Dbase server and run the application no problems (outside of application glitches) but this is where the problem comes in ...

When clients try to connect to the citrix server they have a problem executing the application attached to the database. This problem only begins happening after maybe 4 hours sometimes clients can connect throughout the day (8 - 5) and about the last hour or so start having issues where clients are kicked out of the application. The issue is not a connection to the citrix server because at any point during the day the clients can connect to the citrix server but the execution of the application associated with the Dbase is the problem that will not start. If I reboot the server (Citrix) everyone can connect again no problem for again the same period of time if all users are logging in. I have 2 servers and about 50 users split between the two. If users were to connect to the Citrix boxes during this problem time all other applications will run lightning speed but this particular app. with the Pervasive SQL dbase will not. If will not kick or lock the citrix users all at one time but almost one by one. The systems are clean from any virus or spyware, they are firewalled to only allow necessary ports from the outside. If I try to run the application locally on the Citrix machines during this problematic time the application still will not open or will take forever to even open (timed at 14 minutes on one instance). If I start logging people off the server one by one the application will eventually come up faster. Meanwhile as I mentioned the servers are more than capable of handling the load ... my cpu using when everyone is logged into the server is about 7 to 15% (max) and the 15 is when I have more than half on one machine. I have work with the application designer (Mom and Pop type company) but their programmers have only concluded that the problem is with something holding up the database from starting. Citrix says it is a Pervasive issue and Pervasive wants to point fingers at Citrix (typical). The servers are running CA antivirus and I have made the application exempt for the AV to prevent scanning of the app and the dbase. All the updates are done on the servers so everything is up to date there. The version of Pervasive is 8. The server also have static addresses assigned on the same private network. Hopefully this is enough info for anyone who might have experienced a similar incident and has any ideas. Thanks guys and gals.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

the same problem

by systems In reply to Citrix, 2003 Servers and ...

i install on new Citrix 2003 Pervasive client 8.7 running Accpac ver 5.3a and have bad performance too.
users running Accpac with Citrix Web cleint and is is very slow.
Pervasive told me to install SRV 2,but no change
I just start with this probelm and i will keep you informed if i find some new answers
Isaac

Collapse -

by systems In reply to Citrix, 2003 Servers and ...

Ken,
e-mail to me when you available and i will call you,i resulted my problem between Accpac and Pervasive
Isaac
Systems@armadale.on.ca

Collapse -

Citrix / Pervasive Problem

by whitmora In reply to Citrix, 2003 Servers and ...

Did anyone find a solution to your Pervasive / Citrix problem...
ie.When clients try to connect to the citrix server they have a problem executing the application attached to the database.

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums