Question

Locked

DNS entry will not update

By jhender31 ·
I recently changed a server's ip address to a static address from a dhcp address and after doing so the entry in DNS will not update. I tried to delete the entry and reregister with ipconfig/registerdns and that is unsuccessful. The server is a domain member and I am a domain admin logged in. There is a reverse lookup zone for this subnet and other servers on this subnet can update thier records after an ip change just fine.

The system failed to register host (A) resource records (RRs) for network adapter
with settings:

Adapter Name : {6FF350D4-9DC6-4DE1-90A5-70BDF2995432}
Host Name : USINLRMDS03
Primary Domain Suffix : noam.cemexnet.com
DNS server list :
10.30.22.114, 10.30.22.115
Sent update to server : 10.30.22.114
IP Address(es) :
10.30.177.8

The reason the system could not register these RRs was because of a security related problem. The cause of this could be (a) your computer does not have permissions to register and update the specific DNS domain name set for this adapter, or (b) there might have been a problem negotiating valid credentials with the DNS server during the processing of the update request.

You can manually retry DNS registration of the network adapter and its settings by typing "ipconfig /registerdns" at the command prompt. If problems still persist, contact your DNS server or network systems administrator. For specific error code, see the record data displayed below.

Also, the ip information for the NIC is correct(ip, subnet, gateway, dns servers etc.) and the check box to update dns is checked.
Any help or sugestions will be most appreciated.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

I would try the following

by Dumphrey In reply to DNS entry will not update

reboot the computer then try 1)ipconfig /registerdns. If that fails, check the tcp/ip properties/advanced/dns and make sure the "register this connections addresses in DNS" box is checked.
2)Try ipconfig /registerdns again. Hopefully it worked.
3)Next I would try manualy adding an A record to DNS with the correct info. That may fix it.
Post back if any of that does or does not help. Any extra info you have may help solve it as well.

Collapse -

manually update

by lowlands In reply to DNS entry will not update

I believe that by default dynamic update is not allowed on the RR (reverse lookup) zone in MS DNS.

It is also possible that the reverse entry still exists and that the Computer account does not have access to it. In that case, try deleting the entry and try again.

Collapse -

Tried all suggested

by jhender31 In reply to manually update

Thank you for your replies. I have tried all suggested options and dynamic updates are enabled for us.

I have removed the recoed and also tried to manually add it and that does not help resolve the hostname to the proper address. When pinging the hostname it still resolves to the old address which was dhcp and was registered in dns by the dhcp server.

Collapse -

You may need to get a little

by Dumphrey In reply to Tried all suggested

drastic. Remove the computer from the domaine, remove all entries for the compurt from dns, forward and reverse. Add the computer back to the domaine.
Of course, it may be worth clearing out dns first, then attempting to ipconfig /registerdns again before removing from domaine.

Collapse -

Do you have WINS?

by lowlands In reply to Tried all suggested

It is possible a WINS entry remains.
Another option is that the old name/ip address combo is in the DNS cache

try <b>ipconfig /flushdns</b> and see if that helps.

Some other possible issues can be found here:
http://www.eventid.net/display.asp?eventid=11165&eventno=1633&source=DnsApi&phase=1

most of those are related to the domain suffix, so doublecheck that too

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums