General discussion

Locked

F5 Networks BigIP LTM, Share Point 2007, and Integrated Reporting Svcs

By tarundlejr ·
We were looking to load balance MOSS 2007 behind an F5 LTM (with SSL off-loaded the the LTM.) We followed the deployment guide provided by F5 Networks and everything seemd to be fine. However, when we tried to do anything with Integrated Reporting Services, we received an error that was less than helpful. The strange part is that we were able to take the LTM out of the configuration and everything worked.

The problem was a combination of Share Point Alternate Access Mappings (AAM) and the Share Point front end webservers resolving the FQND to the F5 virtual server. The result was that inter-server communication between the webservers and the SQL reporting server broke with the resulting error about "...Make sure that the Reporting Server is in Share Point Integrated Mode."

The fix is actually obvious after the fact. It's a combination of two things:

1) Spoofing the local host file on each of the front end SharePoint web servers to resolve the public FQDN to themselves.

2) We took out the Alternate Access Mappings (AAM) and used an iRule on the F5 to rewrite the http stream on the outbound traffic; modifying any URLs in the stream to point to https://FQDN instead of http://FQDN. Only the client's outside of the network needed the https.

Thats the fix. It took opening support calls with both F5 and Microsoft to get to this point. We went through several remote support sessions, took TCP dumps, Sniffed traffic between all the servers, etc. And, although the solution was worked out by myself and another engineer in house, both F5 and Microsoft were helpful.

If you have any questions, please reply as I'll keep an eye on this thread.

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Back to Networks Forum
0 total posts (Page 1 of 1)  

Related Discussions

Related Forums