General discussion

Locked

Fix a dll problem when opening NWAdmn

By JJW ·
Everytime I open NetWare Administrator, I recieve an error message telling me uvxwnds32.dll is either corrupt or missing. I just installed it, so I don't think it is corrupt, and I know it's not missing, so I don't know what the problem is. I've searched knowledgebase to no avail. Thanks in advance.

Justin

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Fix a dll problem when opening NWAdmn

by Richard.McKinney In reply to Fix a dll problem when op ...

Most likely this is a path issue. Make sure that the drive you are using is mapped as a search drive. The syntax is:

map root s16:=server\sys:public


Rich

Collapse -

Fix a dll problem when opening NWAdmn

by JJW In reply to Fix a dll problem when op ...

The search mapping is correct and the dll problem persists.

Collapse -

Fix a dll problem when opening NWAdmn

by rwscc In reply to Fix a dll problem when op ...

Create a shortcut to NWadmin. Make sure the shortcut specifies the working directory to be the same as the directory NWadmin is in. I always do this by right-click-hold on nwadmn32.exe and dragging it to the desktop. Then chose the create shortcut option when the right mouse button is released.
Also be sure you have the current release of Novell's client installed. The microsoft clients for netware never run nwadmin correctly.

Collapse -

Fix a dll problem when opening NWAdmn

by JJW In reply to Fix a dll problem when op ...

I have the most current client, and I am running the program from a shortcut.

Collapse -

Fix a dll problem when opening NWAdmn

by JJW In reply to Fix a dll problem when op ...

Neither of the posted responses fixes the problem. What I did find was that installing IPX on the client did solve the problem. Go figure that one. Installing an additional protocol is not an acceptable solution for me, however, and I consider the question open.

Collapse -

Fix a dll problem when opening NWAdmn

by rogerndgreen In reply to Fix a dll problem when op ...

Can't answer why adding IPX to the client solved the problem, but at least it tells me that you are running NW 5.x (doesn't it?) If this is the case, why not use Console1?
Have you loaded the latest service pack for your version?
I have had similar problems on a NW4.x network, and had to add the search path to include server:sys:\public\nls to get it to work 100% of the time.
Another thought is, does the DLL exist on the server? If it does, and isn't needed on the PC, then try renaming the version on the PC, and reboot the PC (to ensure that it isn't in memory) before trying to run NWadmin again.
Also, a real basic question here, but I want to check, you are using Novell's client aren't you, not Microsoft's?

Does this help any?
Roger

Collapse -

Fix a dll problem when opening NWAdmn

by JJW In reply to Fix a dll problem when op ...

Thanks Roger. You provide a lot of helpful suggestions.

I am an Novell Instructor and the server (NetWare 5.1) on which I was having this problem no longer exists, but patching the server did not help and the dll was on the server.

Nonetheless, I appreciate your suggestions and I will try them next week, when I will be teaching another NetWare 5.1 class. Take care and thanks again.

Justin

Collapse -

Fix a dll problem when opening NWAdmn

by JJW In reply to Fix a dll problem when op ...

This question was closed by the author

Back to Networks Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums