General discussion

Locked

help needed IGMP snooping on cisco 7606

By apv ·
Here is my requirement:

+------------+
| |
P1/V1====| |P3/V3
| Cisco 7606 |===== Multicast source
P2/V2====| |
| |
+------------+

* IGMP reports will be received over P1 and P2.
* P3 is connected to a multicast source and will act as the mrouter interface for the IGMP snooping VLAN.
* V1, V2 and V3 are 802.1Q VLAN tags.

Questions are:

1. Can V1, V2 and V3 be different? I tried configuring the following and it doesn't see to work. The joins are not getting recognized.

Config for P3:
--------------
interface GigabitEthernet3/29
no ip address
switchport
switchport access vlan 220
switchport trunk native vlan 220
switchport trunk allowed vlan 220
switchport mode trunk
end

Config for P1:
--------------
interface GigabitEthernet3/30
no ip address
switchport
switchport access vlan 220
switchport trunk native vlan 220
switchport trunk allowed vlan 190
switchport mode access
end

Config for P2:
--------------
interface GigabitEthernet3/32
no ip address
switchport
switchport access vlan 220
switchport trunk native vlan 220
switchport trunk allowed vlan 195
switchport mode access
end
!
Config for VLAN 220:
--------------------
interface Vlan220
ip address 113.11.1.1 255.0.0.0
ip igmp snooping mrouter interface GigabitEthernet3/29
ip igmp snooping querier
end

eshow ip igmp interface vlan 220
Vlan220 is up, line protocol is up
Internet address is 113.11.1.1/8
IGMP is disabled on interface
Multicast routing is disabled on interface
:
IGMP snooping is globally enabled
IGMP snooping is enabled on this interface
IGMP snooping fast-leave is disabled and querier is enabled
IGMP snooping explicit-tracking is enabled on this interface
IGMP snooping last member query interval on this interface is 1000 ms

Let me know if I missed out something. I tried with untagged links over P1 and

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by icmp30 In reply to help needed IGMP snooping ...

If you want multicast to work across different vlans you'll have to enable multicast routing. Something along the lines of

multicast routing
ip pim rp-address 113.11.1.1
interface <p1>
switchport
switchport mode access
switchport access vlan 190
interface <p2>
switchport
switchport mode access
switchport access vlan 195
interface <p3>
switchport
switchport mode access
switchport access vlan 220
interface vlan190
ip address <whatever>
ip pim sparse-mode
interface vlan195
ip address <whatever>
ip pim sparse-mode
interface vlan220
ip address 113.11.1.1 255.0.0.0
ip pim sparse-mode


I've never had to add any "ip igmp" commands - the default behavior works for me.

Back to Networks Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums