General discussion

Locked

IIS 5.0 configuration with ASP.NET 1.1

By deemurphy_us ·
Don't know if I am in the right place but:

I had ASP.NET 1.0 installed, I uninstalled it and
installed ASP.NET 1.1. When I bring up Visual
Studio and try to create a project, I now get

Visual Basic.NET has detecwted that the web server is
running ASP.NET 1.0. The web application you are
creating or opening can be configured to be compliant
with ASP.NET 1.0

However the application will not be able to use the
new features from ASP.NET 1.1.

If I choose to make the application compliant with
ASP.NET 1.0 I get:

The default web access mode for this project is set to
file share, but the folder at
http://localhost/projectname can not be opened with
the path C:\inetpub\wwwroot\projectname. The error
was:

Unable to create web project. The file path c:\Inetput\www\projectname does not
correspond to the url http://localhost/projectname.
The two need to map the the same server location.
HTTP error 404: Not Found.

I even stopped the server, created a new directory called project, made it a share directory with the web server and get the same thing.

Also does the web server have to run at port 80, I changed it to port 90 becasue something else is using port 80 before the web server can start.

Thanks for any and all help.

Dee
deemurphy_us@yahoo.com


Darlene D. Murphy

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by rick_b In reply to IIS 5.0 configuration wit ...

Have you had a chance to take a look at this.
http://www.iisfaq.com/Default.aspx?tabid=3164

Collapse -

by sagardays In reply to IIS 5.0 configuration wit ...

Check this link....this gives u complete information....

http://support.microsoft.com/default.aspx?
scid=kb;en-us;306005

All the best

Collapse -

by sagardays In reply to IIS 5.0 configuration wit ...

After you install the Microsoft .NET Framework Software Development Kit (SDK) or Visual Studio .NET, Microsoft Internet Information Service (IIS) mappings are created to associate the new file extensions and settings for ASP.NET. If you did not have IIS installed when you ran the SDK or Visual Studio Setup, or if you uninstalled and reinstalled IIS after you ran the SDK or Visual Studio Setup, those settings will not be in place. You experience unexpected behavior when you try to view ASP.NET pages.

When you try to create a new ASP.NET Web application in Visual Studio .NET 2003, you receive the following error message:
Visual Studio .NET has detected that the specified Web server is not running ASP.NET version 1.1. You will be unable to run ASP.NET Web applications or services.
MORE INFORMATION
To fix IIS mappings for ASP.NET, follow these steps:1. Run the Aspnet_regiis.exe utility: a. Click Start, and then click Run.
b. In the Open text box, type cmd, and then press ENTER.
c. At the command prompt, type the following, and then press ENTER:
"%windir%\Microsoft.NET\Framework\version\aspnet_regiis.exe" -i
In this path, version represents the version number of the .NET Framework that you installed on your server. You must replace this placeholder with the actual version number when you type the command.

2. Register the Aspnet_isapi.dll: a. Click Start, and then click Run.
b. In the Open text box, type the following, and then press ENTER:
regsvr32 %windir%\Microsoft.NET\Framework\version\aspnet_isapi.dll
Regsvr32 returns the results of the registration.

Collapse -

Thanks for answering the question!

by rilian In reply to

Your answer solved my problem.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums