Question

Locked

Javascript problem

By jimmy-jam ·
I am building an image map based on a rack diagram picture which contains IP addresses. I built the map and it works fine I am able to set up a hyperlink on all of the IP's and just for grins assigned an arbitrary url to them. My goal though is to lauch remote desktop so I can sign into the clicked server. Here is what I've got. When I click the link I get an error that states "Automation Server can't create object" here is the code.

<script language="JavaScript">
function CXR02RDP()
{
RDPObject = new ActiveXObject("WScript.Shell")
RDPObject.Run("mstsc.exe /v:192.168.128.12") ;
}

</script>

Thanks

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Check your syntax.....

by ThumbsUp2 In reply to Javascript problem

... where's the semi-colon for the variable declaration?

Don't you just hate syntax?

...

Collapse -

Hmmm... that didn't work either

by jimmy-jam In reply to Check your syntax.....

and yes I do hate syntax I can't tell you the number of times I've been burned by it :)

Any other thoughts? Could the way I'm calling the function be causing a problem? I am calling it from a hyperlink using the following.

<area shape="rect"
coords="539,378,636,390" href="javascript:CXR02RDP()">

Collapse -

So maybe it did work but...

by jimmy-jam In reply to Check your syntax.....

My browser security setting weren't letting the script execute. I hate that more than syntax.

Collapse -

This could be your answer, or maybe not. :)

You need to tweak the properties of the level that the site is in. Tools ?
Internet Options? ? choose tab Security ? click button Custom level ? scroll
to 'Run ActiveX controls and plug-ins' ? select ?prompt? or ?enable?.
Presumably something 's changed there.

If that setting didn't fixed the problem, try some of the others in that section. Turns out the problem could be resolved by enabling the following setting "Initialize and script ActiveX control not
marked as safe."

Please post back if you have anymore problems or questions.

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums