General discussion

Locked

LanCard Slow

By Net Dude ·
Hi,
I am having problem with my lan card. its a new pentium 4 PC, somehow my LanCard does trasnmit data but not at normal rate instead very slow. I know my connection is fine, I have tried changing cable, network patch, but it seems to me that the problem is with Built in Lancard.
I have Broadcom NetXtreme 57xx Gigabit C adapter. sometimes it is extremely fast and after a while becomes very slow.
I just want to make sure before I claim for warranty.
Any ideas, would be higly appreciated.

Thank you

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Need more info..but try these solutions

by Why Me Worry? In reply to LanCard Slow

Here are a few things to consider:

1. Is the NIC set to autonegotiate speed and duplex when the port setting on the switch is hard set to say 100Mbps/Full Duplex?

2. If both switch and NIC are set to autonegotiate, there may be an issue with commmunications where both devices cannot agree upon a negotiated speed and duplex, thus causing dropped packets and inconsistent connection speeds. I would opt to hard set both ends of the communication channel to see if that fixes the issue.

3. Look at the NIC's settings and see if you can increase the packet buffers to allow for more data to be sent and received.

Collapse -

Drivers

by khigh In reply to LanCard Slow

I've had a problem with the NetXtreme 57xx series before where Windows didn't recognize it correctly and installed the wrong drivers. I had to download the latest drivers, and install them to get it to work correctly.

Collapse -

ewwwwwwwwwww Broadcom

by fungus-among-us In reply to Drivers

I've had tons of issues with this brand of NI. Usually built into the systemboard. Windows 2Kpro and Windows XP pro failed to properly detect and load the "correct" drivers as well. Had to maually download and install drivers for this comany's NIC. Our old DELL optiplexs came with 3Com 905 NICS that we used instead of the onboard broadcom NICs, since we're not utilizing gigbit ethernet anyway.

Try getting the drivers directly from the motherboard manufacturer (if an integrated NIC), or go to Broadcom's site and get the latest "certified" drivers.

Collapse -

lan card slow, strange

by Net Dude In reply to ewwwwwwwwwww Broadcom

thank you for your reply.
but even after downloading new drivers and installing them i cannot get my lancard to work properly. I have to disconnect and then reconnect to make it work fast for a while.
it is under warranty but before i do that are there anyother suggestions.

thank you again.

Collapse -

Since it's integrated

by khigh In reply to lan card slow, strange

I'm out of ideas. Mine was too, but unistalling it, loading the new drivers, and then reinstalling it fixed my problem.

If it was a card, I'd say try a different slot, but that's out of the question here.

Sorry I can't be more help.

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums