Social Networking

Our forums are currently in maintenance mode and the ability to post is disabled. We will be back up and running as soon as possible. Thanks for your patience!

Question

Locked

Media Player plays but Windows Explorer says CD's are blank!

By shai.shahar ·
Dear TechRepublic,
I have a problem that is driving me crazy..and am hoping you can help.
I run Windows XP Pro on a relatively clean 40gb PC, with [matushita] DVD Player [E: Drive] and [SONY CD-RW CRX160E] CD-ROM burner.
I also have Nero Ultra 6 installed which can burn Cd's VCD's, etc.

Everything worked perfectly until I used the Nero to burn some VCD's of film clips from my band in performance. That worked, the VCD's worked..I felt fine, closed the system normally..went to sleep.

Next day I try ripping one of my OWN Cd's into mp3 for a myspace site for my band..but uh-oh..CD is not automatically playing..in fact Windows Explorer can't find the CD...or any CD!
Every CD I insert either isn't recognized as being in the drive..or it is recognized as having 0 bytes. CD-Ex [my ripper] can't find it either.
BUT if i manually start Wedia Player, or Winamp I can locate the files [.cda] and play them.
This is the same on major label store-bought music CD's.
I have checked device manager and it says everything is working perfectly.
I tried uninstalling Nero..problem persists..I tried re-installling Nero..problem perisists.

I tried registry fixers and spybot detectors.
Nothing helps. My CD-Rom drive can still be used to burn Cd's and with a tweak here and there I can get them to play..but I cannot understand why Explorer and other prog's can't 'see' them.
Any ideas..any help..anyone else have this dilemma?
Your comments are much appreciated.
-Shai

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Ask an easy question why don't you????

by OH Smeg Moderator In reply to Media Player plays but Wi ...

If you couldn't access the data on the drives I would have said that some software corrupted the M'Board Drivers and that is what you're problem is but as you can get some Media Players to see the Files that can not be the case.

Only thing that I can think of here is that something within Windows has been corrupted and you need to run some utilities to fix the problem. I would start off with System File Checker all you need do is open the Command Line Interface and type in SFC then press enter. You'll need your original Install or Recovery CD and allow it to replace any altered files.

This will remove any Service Packs or Patches but it should return the system to New condition and you should have your Optical Drives back working normally.

But with anything like this before starting make a full Backup of all your data before proceeding as in a worst case scenario you'll need to wipe the HDD and install the OS from scratch which will cure any problems that you have unless a Patch has caused the problems in which case when you install the available patches it will again kill off the Optical Drives.

Col

Collapse -

Found the problem {I think] but don't know how to fix it.

by shai.shahar In reply to Ask an easy question why ...

Dear Smeg,

Went looking through the Event Log files to see what internal alerts were registered and I found an entry that explains my problem..thing is I have no idea what to do to fix it. My ELV said it reported a bad memory blok on my CD-ROM1 Drive. I clicked properties and ended up on the support page at Microsoft...[some support..] here is what it says:

Details
Product: Windows Operating System
I 7
Source: Cdrom
Version: 5.2
Symbolic Name: IO_ERR_BAD_BLOCK
Message: The device, %1, has a bad block.

Explanation
The device has a bad block of memory, which Windows attempted to read. The data might be missing or corrupted.


User Action
Do one or all of the following:

Retry the operation.
Clean the physical hard drive.
Use newer media.

Well i have done all three and nothing helps.
Is there a procedure you can recommend that will re-set the memory block in the CD-Rom drive other than reloading XP from scratch and going through the SP updates and customization..yada yada.
Could I replace the drive?
Thanks again for the helpful advice.

Sincerely
-Shai

Collapse -

OK it could be a buildup of rubbish on the Laser Head

by OH Smeg Moderator In reply to Found the problem {I thi ...

You need to either use a Head Cleaner to fix this or pull the Optical Drive Apart and clean up the Head.

What I am supposing here is happening is that the initial Laser is broken into 3 beams the main one for reading data and the other two for leading the main beam and following the main beam to fix any errors that crop up because of scratches or other media in perfections. And in this case Clean the Drive also means the Media as well so don't forget that one.

If this isn't reading the Media properly that will be the cause of the Error Message though it may also mean that there was no CD/DVD in the drive when the machine was originally started as well.

But you basically have two options to look at the Media Surface for damage or marks that can be removed or the Laser Head for a build up of rubbish that is blocking the Laser Beams.

If this doesn't cure the problem it's probably better to just replace the Optical Drives and see what happens. Some Cleaning products that can be used on the Laser Head can damage it and make it block the Laser beams or at least partially cause a loss of intensity which may cause errors to creep in as well.

The reason that you can record but not read is that they use different wave length Lasers to burn than to read so it's possible that the Reading Laser is defunct or at best damaged in some form which is your current problem.

Col

Collapse -

Yes..I think you are right!

by shai.shahar In reply to OK it could be a buildup ...

Found the courage to pop the side panel of my PC and peek inside...EGADS! enough dust in the casing and on the motherboards to make a whole new person!
So I am inclined to think the primary head is dusted up or foggy..will go to my local mediacenter and buy the cleaner kit.

You have been a tremendous help..Thanks!

Collapse -

Nope..that wasn't it. ;-(

by shai.shahar In reply to Yes..I think you are rig ...

Went oput and got the laser lens cleaner for CD/DVD drives but that didn't help at all. Same problem persists.

On another forum I was told that maybe my codec files got corrupted but they offered no solution.
I'm wondering how to reset E & F drives to their original default settings....I think I read somewhere that if you delete the current entries from the files, that they will be reset automatically at the next reboot..but I don't remember which files/folders to go find them

Collapse -

You may have to pull the optical drives apart

by OH Smeg Moderator In reply to Nope..that wasn't it. ;- ...

and clean them out properly though I don't think that is the entire problem here as you can get this system to play Music Media.

Have you tried to use Nero Media Player? To see if there is any difference there?

Short of removing Media Player and reloading it I'm not really sure of what else to suggest.

Col

Collapse -

Managed to work around it, sort of...

by shai.shahar In reply to You may have to pull the ...

Thanks for writing back!

Well, after vacuuming my PC's internals, using a laser lens cleaner and electro-static remover..and feeling good about how new and shiny everything looked, I booted up and found out it didn't solve my E & F Drive recognition prob's.

So I tried the trick I got from another forum..I went into my device manager and de-installed both drives. Then hit restart.
When it rebooted I got a message saying Windows had found new hardware..two new devices..my CD-ROM Player/Writer and my DVD Player but had to reboot again in order for them to properly re-install.

Wonder of wonders my CD's played when I loaded them in and Explorer could find them. Same with a few of the formerly unplayable unreadable DVD's & CD's.

But still..not all programs can find a Cd or DVD in my Drives.
Like AVS DVD can find and play the DVD.and so can VLC but not Media Player.

My ISO Buster [that can normally read anything it finds] insists that I have a blank disc in the E Drive even though the two DVD/DivXX players can read, play and even rip the files on disc.
And that is my problem with Explorer now. I can play and extract files from CD's that Explorer insists are either blank or not even in the drive. And sometimes when I load a CD or DVD in I see the hour-glass and then nothing happens unless I manually engage my player

As for Nero..that was the start of my problems and I have since de-installed it and cleaned out left over registry entries.
Will try reloading and see if it interferes with the other prog's I have and hope for the best.

Greetings from Amsterdam
-Shai

Collapse -

OK Don't install Nero as if you have 2 Burning programs

by OH Smeg Moderator In reply to You may have to pull the ...

Installed you can and do get conflicts.

Instead of removing the Optical Drives you can try removing the IDE Chanel that they are on and allowing the system to reboot. That may cure your current problem.

Lets know how you get on.

Col

Related Discussions

Related Forums