Question

Locked

NAT & Cisco ASA 5505

By lukeward2004 ·
Hi,

Ive recently had a BTNet 10mb leased line put in place, with a BT managed Cisco 1800 series Router connecting to the fibre link.

I have the IP address of the router and I was told I needed to add a firewall that can perform NAT translation in order to
use the leased line, so I bought an ASA 5505.

I have the Outside interface of the ASA connected to the Router and have set it all up to the best of my knowledge however I
cannot seem to get onto the internet or ping externally, I suspect it may be a NAT issue and I need some help.

I have a single route ouside to the BTNet router, which should then handle the routing out onto the internet. I wanted to use
NAT in routed mode.

My Running COnfig on the ASA is below (please note I have changed the IP addresses for security purposes), can someone help?

ASA Version 7.2(4)
!
hostname xxxxxx
domain-name xxxxxx
enable password xxxxxx encrypted
passwd xxxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 194.74.79.232 255.255.255.240
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
domain-name BOOMERANG.LOCAL
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service Allowed_Ports tcp
port-object eq 3389
port-object eq 3390
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
port-object eq pop3
port-object eq smtp
object-group service Allowed_in tcp
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
port-object eq pop3
port-object eq smtp
object-group service DM_INLINE_TCP_1 tcp
group-object Allowed_Ports
group-object Allowed_in
access-list outside_access_in extended permit tcp 194.74.79.224 255.255.255.240
192.168.0.0 255.255.255.0 object-group Allowed_in
access-list inside_access_in extended permit tcp 192.168.0.0 255.255.255.0 any o
bject-group Allowed_Ports log disable
access-list inside_access_in extended permit icmp any any
access-list inbound extended permit tcp any any eq smtp
access-list inbound extended permit tcp 194.74.79.224 255.255.255.240 192.168.0.
0 255.255.255.0 object-group Allowed_in
access-list inside_access_out extended permit tcp 192.168.0.0 255.255.255.0 194.
74.79.224 255.255.255.240 object-group Allowed_Ports
access-list inside_access_out extended permit icmp any any
access-list inside_access_out extended permit ip any any
access-list inside_access_out extended permit tcp any any object-group Allowed_P
orts
access-list outside_access_out extended permit icmp any any
access-list outside_access_out extended permit tcp 192.168.0.0 255.255.255.0 194
.74.79.224 255.255.255.240 object-group DM_INLINE_TCP_1
access-list outside_access_out extended permit ip any any
access-list outside_access_out extended permit tcp any any object-group Allowed_
Ports
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 194.74.79.233-194.74.79.240
global (outside) 1 interface
nat (inside) 1 192.168.0.0 255.255.255.0
access-group inside_access_in in interface inside
access-group inside_access_out out interface inside
access-group inbound in interface outside
access-group outside_access_out out interface outside
route outside 0.0.0.0 0.0.0.0 194.74.79.233 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.0.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b28b49c174f21caa4e9073e7f6f31467
: end

Short of getting a cisco support contract I dont know what else to do!!

Please help

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Forums