Question

Locked

nat issue with inside and dmz interfaces on asa firewall...

By techrepublic ·
Hello experts, I have a NAT issue which is bugging me. Got a 3 armed ASA with inside, outside and dmz interfaces. trying to get communication between a computer on the inside (192.168.101.22) and a computer in the DMZ(98.23.65.130). Tracing packets i get the messages below:

------------------------------------

%PIX|ASA-3-305005: No translation group found for protocol src interface_name:dest_address/dest_port dst interface_name:source_address/source_port
A packet does not match any of the outbound nat command rules.

This message indicates a configuration error. If dynamic NAT is desired for the source host, ensure that the nat command matches the source IP address. If static NAT is desired for the source host, ensure that the local IP address of the static command matches. If no NAT is desired for the source host, check the ACL bound to the NAT 0 ACL.

------------------------------------

Here's the relevant config - external IP's have been modified to protect the innocent.

: Saved
:
ASA Version 7.2(3)
!
hostname ASA5505-01
domain-name whatever.com
names
name 192.168.101.20 GVDEN-01
name 192.168.101.22 GVRDEN-02
name 192.168.101.15 DVR
name 98.23.65.130 GVRWEBDEN-01
name 98.23.65.131 GVRWEBDEV-01
name 98.23.65.132 GVRESXDEN-01
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.101.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 86.212.78.117 255.255.255.248
!
interface Vlan12
nameif DMZ
security-level 50
ip address 98.23.65.129 255.255.255.248
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
speed 100
duplex full
!
interface Ethernet0/2
switchport access vlan 12
!
interface Ethernet0/3
switchport access vlan 12
!
interface Ethernet0/4
switchport access vlan 12
!
interface Ethernet0/5
switchport access vlan 12
!
interface Ethernet0/6
switchport access vlan 12
!
interface Ethernet0/7
switchport access vlan 12
!
banner exec *** NOTICE $(hostname) is to be logged into or used only by authorized $(domain) personnel, unauthorized use of this system is unlawful and maybe subject to civil and/or criminal penalties. Notice any use of system is logged and maybe used as evidence in court. ******
boot system disk0:/asa723-k8.bin
ftp mode passive
clock timezone MST -7
clock summer-time MDT recurring
dns server-group DefaultDNS
domain-name gvrmetrodistrict.org
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service Vranger tcp
port-object range 6342 6342
port-object range https https
port-object range 51000 51002
port-object range 902 902
port-object range ssh ssh
port-object range 49152 49154
access-list outside_access_in extended permit udp any any eq domain
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp object-group GGT host 86.212.78.113 eq 3389
access-list outside_access_in extended permit tcp object-group GGT host 86.212.78.114 eq 3389
access-list outside_access_in extended permit tcp any host 86.212.78.114 eq smtp
access-list outside_access_in extended permit tcp any host 86.212.78.114 eq pptp
access-list outside_access_in extended permit tcp object-group GGT host 86.212.78.114 eq https
access-list outside_access_in extended permit tcp any host 86.212.78.115 eq 8200
access-list outside_access_in extended permit tcp any host 86.212.78.115 eq 8016
access-list outside_access_in extended permit tcp any host 86.212.78.115 eq 10019
access-list outside_access_in extended permit tcp object-group GGT host GVRWEBDEN-01 eq 3389
access-list outside_access_in extended permit tcp any host GVRWEBDEN-01 eq www
access-list outside_access_in extended permit tcp object-group GGT host GVRWEBDEV-01 eq 3389
access-list nonat extended permit ip 192.168.101.0 255.255.255.0 192.168.102.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 192.168.101.0 255.255.255.0 192.168.102.0 255.255.255.0
access-list DMZ_access_in extended permit tcp host GVRESXDEN-01 eq ssh host GVRDEN-02 eq ssh
access-list DMZ_access_in extended deny ip any 192.168.101.0 255.255.255.0
access-list DMZ_access_in extended permit ip any any
access-list inside_nat0_outbound extended permit ip 192.168.101.0 255.255.255.0 192.168.102.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu DMZ 1500
no failover
monitor-interface inside
monitor-interface outside
monitor-interface DMZ
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (DMZ) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 86.212.78.113 GVDEN-01 netmask 255.255.255.255
static (inside,outside) 86.212.78.114 GVRDEN-02 netmask 255.255.255.255
static (inside,outside) 86.212.78.115 DVR netmask 255.255.255.255
static (DMZ,outside) GVRWEBDEN-01 GVRWEBDEN-01 netmask 255.255.255.255
static (DMZ,outside) GVRWEBDEV-01 GVRWEBDEV-01 netmask 255.255.255.255
static (DMZ,outside) GVRESXDEN-01 GVRESXDEN-01 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group DMZ_access_in in interface DMZ
route outside 0.0.0.0 0.0.0.0 86.212.78.118 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
! The following host entries are incomplete; they await a community string.
snmp-server host inside GVDEN-01
snmp-server host inside GVRDEN-02
snmp-server location Denver
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set 3DES/MD5 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 86400
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 80.59.54.117
crypto map outside_map 1 set transform-set 3DES/MD5
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 21
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect pptp
!
service-policy global_policy global
prompt hostname context

Any idea how to fix this? I'm a newbie when it comes to troubleshooting NAT. Any help is greatly appreciated. Thanks all.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

NO nat (dmz)

by SYNner In reply to nat issue with inside and ...

You don't have a nat for the DMZ network. You have a global for the DMZ network but not a nat.

Collapse -

err...

by techrepublic In reply to NO nat (dmz)

So I need a dynamic entry for the dmz network to the inside??

Thanks again

Collapse -

NAT

by NetMan1958 In reply to err...

See this article:
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008046f31a.shtml

Scroll about 3/4 of the way down and there is a section on static nat and shows a diagram with a DMZ.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums