General discussion

Locked

Port won't close after use

By smundine ·
I am running Windows 98 on a PIII 650Mhz system. I have a USRobotics v90 internal modem. I have to delete the modem everytime before I shut down so that the system will reconfigure it upon startup. If I use the modem then disconnect then try to connect again I will get an error message 630. When I run diagnostics then on modem it says that it can't open port or port is already open. I show an ACPI controller using IRQ9 which is the same interrupt the system assigns to my modem when I startup. If I try to change the interrupt to IRQ3 or 4 it says it is in use by com1 and com2. If I try to use Com1 thru 4 it tells me that they are in use.

This conversation is currently closed to new comments.

24 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Port won't close after use

by calves In reply to Port won't close after us ...

A couple of things to check:
first look under other devices on control panel system, see if you have any unkown devices there. If you do, check the resources and see if it is using the modem resources. Click on update driver and point to your 3com CD.
If you do no0t have any unkown devices, check out the 3COM web site for newer drivers.

Good Luck!

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by ghobgood In reply to Port won't close after us ...

Remove the modem... Go into Bios and disable com 2, save and reboot

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by riszan In reply to Port won't close after us ...

Go into device manager and remove modem, reboot pc and go into your Bios, disable com port 2, save seetings and reboot, the computer will readd the modem and you should be fine. you might also need to remove the com ports in device manager so the computer can reconfigure your com ports.

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by tuck46 In reply to Port won't close after us ...

I would try first using string
ATZ in the extra settings to bring modem back to factory settings. If that fails to work, you will probally have to uninstall and reinstall the modem

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by jun1cez1 In reply to Port won't close after us ...

To smundine,

You definitely have a system config error since US Robotics modems are never designed to use IRQ9. The problem your facing is that the modem or the port that you are using is infact using the programmable Interrupt Controller's IRQ resources.
If you are using win98, you may need to either re-install the OS or upgrade to Win98SE. Also, since you did not specify what kind of computer it is, you may also need to verify to the manufacturer if they such an issue regarding their Hardware.
In the meanwhile, go to system+device manager and then system devices (bottom), see if there's any entry that says motherboard resouces twice or more, if there is, you need to reset your bios specifically COM ports.
That i believe will help except its up to you how far can you play with computer most delicate area "BIOS".
Another important thing, IF the modem is still fairly new, it may be necessary for you to read the entire documentation just to see if they got any issue regarding this. If not, downloadin

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Back to Desktop Forum
24 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums