Question

Locked

problems with cisco router and dhcp client

By jollykong ·
problems with dhcp.
i have a cisco 1811 router that i connect to the internet through a cablemodem. I use dhcp client on the wan port to get my ip addr. the problem is that when I reload the router I can?t get a IP address for my Ethernet port. I?ve tried many combinations of resetting the modem and changing Ethernet port states (shutting down, additional client params (client-id, hostname), renewing and releasing dhcp, stopping dhcp service, no ip address and ip address dhcp, allowing any ip and udp traffic. If I erase the configuration files and reload I can get a ip, and then if I (conf)#no ip address and (conf)#ip address dhcp I can get a different IP.
If I try to renew dhcp after a reload I get error : not in bound state.
If I don?t have the Ethernet port up and connected after I erase and reload then I will not get a ip address (this seems to be the only time I can get a address).
And some debug output:
*May 12 23:53:44.519: Hostname: Router
*May 12 23:53:58.831: DHCP: Try 10 to acquire address for FastEthernet0
*May 12 23:53:58.**1: DHCP: allocate request
*May 12 23:53:58.**1: DHCP: new entry. add to queue, interface FastEthernet0
*May 12 23:53:58.**1: DHCP: SDiscover attempt # 1 for entry:
*May 12 23:53:58.**1: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet0
*May 12 23:53:58.**1: Temp sub net mask: 0.0.0.0
*May 12 23:53:58.**1: DHCP Lease server: 0.0.0.0, state: 1 Selecting
*May 12 23:53:58.**1: DHCP transaction id: BAB
*May 12 23:53:58.**1: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*May 12 23:53:58.**1: Next timer fires after: 00:00:04
*May 12 23:53:58.**1: Retry count: 1 Client-I cisco-0025.4562.91c4-Fa0
*May 12 23:53:58.**1: Client-ID hex dump: 636973636F2D303032352E343536322E
*May 12 23:53:58.**1: 393163342D466130
*May 12 23:53:58.**1: Hostname: Router
*May 12 23:53:58.**1: DHCP: SDiscover: sending 293 byte length DHCP packet
*May 12 23:53:58.**1: DHCP: SDiscover 293 bytes
*May 12 23:53:58.**1: B'cast on FastEthernet0 interface from 0.0.0.0
*May 12 23:54:02.519: DHCP: SDiscover attempt # 2 for entry:
*May 12 23:54:02.519: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet0
*May 12 23:54:02.519: Temp sub net mask: 0.0.0.0
*May 12 23:54:02.519: DHCP Lease server: 0.0.0.0, state: 1 Selecting
*May 12 23:54:02.519: DHCP transaction id: BAB
*May 12 23:54:02.519: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*May 12 23:54:02.519: Next timer fires after: 00:00:04
*May 12 23:54:02.519: Retry count: 2 Client-I cisco-0025.4562.91c4-Fa0
*May 12 23:54:02.519: Client-ID hex dump: 636973636F2D303032352E343536322E
*May 12 23:54:02.519: 393163342D466130

And my config:
Current configuration : 1762 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname c34-16-11-202
!
boot-start-marker
boot-end-marker
!
enable secret 5
!
no aaa new-model
!
resource policy
!
no ip source-route
!
!
ip cef
!
!
no ip bootp server
no ip domain lookup
ip name-server 208.180.42.68
!
username jollykong privilege 15 password
!
interface FastEthernet0
ip address dhcp client-id FastEthernet0 hostname c34-16-11-202
ip access-group 100 in
no ip unreachables
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
ip address 172.24.154.69 255.255.255.0
ip access-group 110 in
ip nat inside
ip virtual-reassembly
!
interface Async1
no ip address
encapsulation slip
!
no ip classless
!
!
no ip http server
no ip http secure-server
ip nat inside source list 110 interface FastEthernet0 overload
!
access-list 100 deny ip 10.0.0.0 0.255.255.255 any
access-list 100 deny ip 172.16.0.0 0.15.255.25 any
access-list 100 deny ip 192.168.0.0 0.0.255.255 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 deny ip host 255.255.255.255 any
access-list 100 permit ip any any
access-list 110 permit ip 172.24.154.0 0.0.0.255 any
no cdp run
!
control-plane
!
line con 0
line 1
line aux 0
line vty 0 4
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
End


Thanks jk

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Networks Forum
0 total posts (Page 1 of 1)  

Related Discussions

Related Forums