Reinstall Remote Desktop for 2k3

By dwdino ·
We have a windows 2k3 server with Remote Desktop enabled for management. One day we needed to modify the settings are found we are unable to remote in. We installed VNC as a workaround.

I have verified service settings, configuration, permissions, group policy, firewall, dll versions, et al...

Anyone have this experience or know of a method to reset TS to "factory default"?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Remote Desktop

by p.j.hutchison In reply to Reinstall Remote Desktop ...

1. Open System control panel
2. Select Remote tab
3. Un-tick Remote Desktop to disable (default)
3. Goto 'Select Remote Users' and clear out all users listed.

You should now be at default.
1. Once Remote Desktop is enabled, it should start the 'Terminal Services' service.
2. Access it via Firewall, allow Remote Desktop in its properties.
3. Add users to the 'Remote Desktop users' group on the server.

Collapse -

Thanks - Solved

by dwdino In reply to Remote Desktop

Had already been that route.

Researched more into TS components and isolated registry keys. Found many keys to be "corrupted". The keys appeared to be more like a TS app server than remote admin.

I proceeded to recreate all registry settings from a known good server. Rebooted and all worked out.

Collapse -

Same problem

by ojealexis532 In reply to Thanks - Solved

I have the same issue. Care to share what reg keys you edited?


Related Discussions

Related Forums