Question

  • Creator
    Topic
  • #4144611

    SSH permission denied

    Locked

    by ali1shaarbaf ·

    About a month ago, I set up Pi hole on a ROC-RK3328-CC (Renegade). Keep in mind during the install, I had to make it’s IP static. Randomly Pi hole stopped working but that is not what’s bothering me. Now, I can’t SSH into it, and it has stayed the same IP address even after turning off static IP. It gives me the same message on the terminal: Port 22: Connection refused. I have no clue why this is happening. Can somebody please give me some knowledge or a solution. Also, it is possible that the port has changed and I did not do the IP thing correctly. If it is found out that the port has changed, can someone tell me how to SSH through the new port. Thanks in advance to anyone that helps.

All Answers

  • Author
    Replies
    • #4144746
      Avatar photo

      It’s just a pihole.

      by rproffitt ·

      In reply to SSH permission denied

      Wipe out, reinstall.

      • #4144765

        Reply To: SSH permission denied

        by ali1shaarbaf ·

        In reply to It’s just a pihole.

        @rproffitt I have already tried that before and it hasn’t worked. I think my effort to make the IP dynamic was done incorrectly but even if, I wouldn’t know. Thanks a lot for trying to help. I really appreciate it!
        (I accidentally made a new post lol)

        • #4145075
          Avatar photo

          Rinse, repeat?

          by rproffitt ·

          In reply to Reply To: SSH permission denied

          When I messed up my Raspberry Pi I had to hook up a monitor, keyboard and mouse so I could fix it since my network access went down.

          I see your board has such connections so you have to do that when it gets that messed up. Or just wipe it out (format) and install the OS and apps again.

        • #4145644

          SOLVED:

          by ali1shaarbaf ·

          In reply to Rinse, repeat?

          For some reason, no matter how many times I re installed the OS, it still stayed static and port 22 stayed closed. So what I did is I installed Ubuntu and disabled the firewall and renabled it by doing ‘sudo ufw disable’ and sudo ufw start’ and it worked fine after that. I also did a ‘sudo service ssh status’ to see if it was running or not. It wasn’t for me so I did ‘sudo apt-get install openssh-server’. It worked after that.

    • #4144763

      Tried and failed

      by ali1shaarbaf ·

      In reply to SSH permission denied

      @rproffitt I have already tried that before and it hasn’t worked. I think my effort to make the IP dynamic was done incorrectly but even if, I wouldn’t know. Thanks a lot for trying to help. I really appreciate it!

      • #4145641

        Reply To: SSH permission denied

        by ali1shaarbaf ·

        In reply to Tried and failed

        For some reason, no matter how many times I re installed the OS, it still stayed static and port 22 stayed closed. So what I did is I installed Ubuntu and disabled the firewall and renabled it by doing ‘sudo ufw disable’ and sudo ufw start’ and it worked fine after that. I also did a ‘sudo service ssh status’ to see if it was running or not. It wasn’t for me so I did ‘sudo apt-get install openssh-server’. It worked after that.

        • This reply was modified 9 months, 4 weeks ago by ali1shaarbaf.
        • This reply was modified 9 months, 4 weeks ago by ali1shaarbaf.
Viewing 1 reply thread