Question

Locked

Trouble with wireless aspect of Cisco 871W router

By halloman ·
Hello. I am having trouble with the wireless networks on my Cisco 871W router. I used the router config guide on this site, and that helped get the networks up and running. But at random points the router will drop all wireless connections on all devices (PC, phone, Wii, PS3, etc) The SSID will show up on my wireless NIC interfaces but it will not add any devices to the network nor will it forward any traffic. The devices connected directly to the router are not affected. This happens roughly every other to every third day. If I restart the router it works fine until it decides to dump everyone again. Anyone have any ideas?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Same Problem

by Kirbo33 In reply to Trouble with wireless asp ...

halloman - I have this same problem. The only way the clients will connect back up is by rebooting the 871w router.

I am running WPA-TKIP.

Collapse -

It might help

by NetMan1958 In reply to Trouble with wireless asp ...

if you post your router's config here.

Collapse -

Router Configuration

by Kirbo33 In reply to It might help

I have to reboot the router, then the wireless clients will connect back up.

Here's my config:

!version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 871W
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-813408114
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-813408114
revocation-check none
rsakeypair TP-self-signed-813408114
!
!
crypto pki certificate chain TP-self-signed-813408114
certificate self-signed 01
30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 38313334 30383131 34301E17 0D303930 38323632 32333935
395A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3831 33343038
31313430 819F300D 06092A86 4886F70D 01010105 000381 00308189 02818100
CF64A9BE 85B6A370 6263F22F 8525F7DB 9DCCB2A9 CE90F073 7E473081 DB824402
4C33BC38 79B4E9F7 C56B3589 C52F5F4B D38D9AAE DC3**27D 97CD0215 0CA77D65
790F50BB A4DF3709 78E29778 9E110E24 EBB24D62 DE61BAEC 4E2382F6 CE1CE900
42CBC43A 4AE4587F 61A733C9 F86979F0 966F2A29 0D2A7AFB 24F8EEC4 1073FAF7
02030100 01A37130 6F300F06 03551D13 0101FF04 05300301 01FF301C 0603551D
11041530 13821138 3731572E 796F7572 6E616D65 2E636F6D 301F0603 551D2304
18301680 14C76C2D 03757303 3F669366 5DED31A1 2FB7B8EF BD301D06 03551D0E
04160414 C76C2D03 7573033F 6693665D ED31A12F B7B8EFBD 300D0609 2A864886
F70D0101 04050003 8181003E ED7C2584 8BA658D5 99F6329E AF3C8ED7 93293CFA
31D7BFD7 1468604B FC1C28B6 9DCB8DF6 B4A6D885 34B7CED4 98145BB1 AFCEB8F1
1CC17645 B2771E79 BE4ACEFB 2C57FF2B 4BE8ABC5 019B2A91 F4789FB3 62BBA528
5DB344AC 85E9679E E9D99CF5 4EF112FE 3EBA6074 181D29B8 14FFAB64 2747979B
8A01EA7C 07AA1E4D 6B3E9B
quit
dot11 syslog
!
dot11 ssid Sunday
vlan 1
authentication open
authentication key-management wpa
wpa-psk ascii 7 ***password***
!
!
dot11 wpa handshake timeout 2000
!
ip source-route
!
!
ip dhcp excluded-address 10.XX.20.200 10.10.20.254
!
ip dhcp pool vlan1-pool
import all
network 10.XX.10.0 255.255.255.0
default-router 10.XX.10.1
lease 0 2
!
ip dhcp pool vlan1-wireless
import all
network 10.XX.20.0 255.255.255.0
default-router 10.XX.10.1
!
!
ip cef
ip domain name yourname.com
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username admin privilege 15 secret 5 ***password***
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description WAN
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers tkip
!
ssid Sunday
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
power local cck 13
power local ofdm 13
power client 13
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
ip address 10.XX.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan1
ip address 10.XX.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
ip nat inside source list 2 interface FastEthernet4 overload
ip nat inside source list 3 interface FastEthernet4 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.XX.10.0 0.0.0.255
access-list 2 remark SDM_ACL Category=2
access-list 2 permit 10.XX.10.0 0.0.0.255
access-list 3 remark SDM_ACL Category=2
access-list 3 permit 10.XX.20.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 30 0
password ***password***
logging synchronous
no modem enable
line aux 0
line vty 0
exec-timeout 30 0
password ***password***
logging synchronous
login local
line vty 1 4
login local
!
scheduler max-task-time 5000
end

Collapse -

Logs

by Kirbo33 In reply to Router Configuration

These are the logs when I can't reconnect:
*Sep 30 20:14:27.542: %DOT11-6-ASSOC: Interface Dot11Radio0, Station LAPTOP-PC 0021.XXXX.2e2a
Associated SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 20:15:38.570: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0021.6
a75.1f2a Reason: Sending station has left the BSS SSID[Sunday]
*Sep 30 20:15:59.426: %DOT11-6-ASSOC: Interface Dot11Radio0, Station LAPTOP-PC 0021.XXXX.2e2a
Associated SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:14:38.046: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0021.6
a75.1f2a Reason: Sending station has left the BSS SSID[Sunday]
*Sep 30 21:14:49.830: %DOT11-6-ASSOC: Interface Dot11Radio0, Station LAPTOP-PC 0021.XXXX.2e2a
Associated SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:15:37.134: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0021.6
a75.1f2a Reason: Sending station has left the BSS SSID[Sunday]
*Sep 30 21:16:00.402: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 001e.5273.1352 Associate
d SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:17:15.294: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 871W 0021.XXXX.2e2a Associ
ated SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:26:40.426: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0021.6
a75.1f2a Reason: Sending station has left the BSS SSID[Sunday]
*Sep 30 21:28:18.338: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 871W 0021.XXXX.2e2a Associ
ated SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:29:36.366: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0021.6
a75.1f2a Reason: Sending station has left the BSS SSID[Sunday]
*Sep 30 21:29:41.594: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 001e.5
273.1352 Reason: Previous authentication no longer valid SSID[Sunday]
*Sep 30 21:30:53.818: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 001e.5273.1352 Associate
d SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:31:09.850: %DOT11-6-ASSOC: Interface Dot11Radio0, Station LAPTOP-PC 0021.XXXX.2e2a
Associated SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:31:15.146: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0021.6
a75.1f2a Reason: Sending station has left the BSS SSID[Sunday]
*Sep 30 21:31:15.906: %DOT11-4-MAXRETRIES: Packet to client 0021.XXXX.2e2a reached max retries,
removing the client
*Sep 30 21:31:16.138: %DOT11-6-ASSOC: Interface Dot11Radio0, Station LAPTOP-PC 0021.XXXX.2e2a
Associated SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:31:23.714: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 001e.5
273.1352 Reason: Previous authentication no longer valid SSID[Sunday]
*Sep 30 21:31:27.042: %DOT11-4-MAXRETRIES: Packet to client 0021.XXXX.2e2a reached max retries,
removing the client
*Sep 30 21:31:39.054: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 001e.5273.1352 Associate
d SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]
*Sep 30 21:32:17.054: %DOT11-4-MAXRETRIES: Packet to client 0021.XXXX.2e2a reached max retries,
removing the client
*Sep 30 21:32:35.730: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 001e.5
273.1352 Reason: Previous authentication no longer valid SSID[Sunday]
*Sep 30 21:32:50.294: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 001e.5273.1352 Associate
d SSID[Sunday] AUTH_TYPE[OPEN] KEY_MGMT[WPA PSK]

Collapse -

More Information

by Kirbo33 In reply to Logs

I searched on the error and found this site:
http://www.cisco.com/en/US/docs/wireless/access_point/12.3_7_JA/configuration/guide/s37err.html

Error Message DOT11-4-MAXRETRIES: Packet to client [characters] reached max retries,
removing the client

Explanation This error message indicates that the access point attempts to poll the client a certain number of times, but does not receive a response. Therefore, the client is removed from the association table. This issue is commonly seen when the client and access point are attempting to communicate in a noisy RF environment.

Recommended Action To resolve this issue, run a carrier busy test on the access point to determine if there is excessive noise in the radio channel spectrum. Attempt to alleviate any unwanted noise. For more information, refer to the "Performing a Carrier Busy Test" section on page 6-26.

If there are several access points in the same area, there might be overlapping the channel signals or possibly other wireless device in the area. Change the access point channel to one of the non-overlapping channels using the access point GUI. Under Network Interfaces, select Radio-802.11. There are three non-overlapping channels: 1, 6, and 11.

I performed a Carrier Busy test and these are my results:

871W#sho dot11 carrier busy

Frequency Carrier Busy %
--------- --------------
2412 100
2417 100
2422 100
2427 100
2432 100
2437 100
2442 100
2447 100
2452 100
2457 100
2462 100

What does this mean? All of the channels are 100 percent busy?

Collapse -

Indeed

by NetMan1958 In reply to More Information

That does show all of those channels are 100% busy. You may have discovered your problem. Were the computers able to communicate over the wireless network at the time you ran that command?

Collapse -

Carrier Busy %

by Kirbo33 In reply to Indeed

Yes - My wireless clients were connected while all channels were at 100 percent.

Why does it fluctuate so much within a 10 second timeframe?

I have the router set to "least congested channel" for frequency.

Any other settings I can adjust?

871W#sho dot11 carrier busy

Frequency Carrier Busy %
--------- --------------
2412 100
2417 100
2422 53
2427 0
2432 0
2437 0
2442 0
2447 0
2452 0
2457 0
2462 0
871W#sho dot11 carrier busy

Frequency Carrier Busy %
--------- --------------
2412 100
2417 100
2422 100
2427 100
2432 100
2437 100
2442 100
2447 100
2452 100
2457 100
2462 100

Collapse -

I will experiment

by NetMan1958 In reply to Carrier Busy %

with my cisco wireless at the office tomorrow and try to come up with some ideas for you. If your clients are able to connect while the channels show 100% busy, that probably isn't the issue. I don't know if that is the norm or not as I've never run that command on anything before. I'll take a look at mine tomorrow and see what it shows.

Related Discussions

Related Forums