General discussion


USB ports work until Windows loads

By snoop_daniels ·
This the most puzzling problem I've ever seen...

System overview:

Home-made system
Abit AV8 Socket 939 Motherboard
AMD Athlon 64 3400+
2.0 GB Ram (can't remember the bus speed)
ATI All-in-Wonder 9600XT
Sound Blaster Live! 24-bit

I have a computer with a USB keyboard and mouse. When I boot the computer I can access the BIOS settings and change them using the USB keyboard, but as soon as windows loads the keyboard quits working. Obviously it's impossible to tell if any of my other USB hardware works before windows loads.

All other ports work fine, which, combined with the fact that they keyboard works in the BIOS setup screen, precludes the possibility that the motherboard is the problem.

I have reformatted the hard drive and reinstalled Windows to no avail, and the CD that came with the motherboard contains no special USB drivers of any kind. The BIOS Setup menu contains absolutely NO options regarding USB settings that I can see.

Device manager shows no USB hubs or controllers in the USB section.

As soon as Windows has loaded, any lights that WERE on that indicated that these devices were working go off.

In addition, I can't think of any particular event that could have caused this problem. I got a message of some kind regarding a virus so I ran a virus scan which turned up nothing. It seems that my USB ports were working, then they weren't.

This problem is even moreperplexing when you consider how many people have the opposite problem: their USB devices don't work UNTIL Windows loads.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by TheChas In reply to USB ports work until Wind ...

Perplexing that nothing shows up in BIOS settings.

Have you tried clearing the CMOS?

What about selecting "default" CMOS settings?

The only other idea that makes any sense is that Windows is installing the wrong drivers for the chip-set and USB controller.

Windows default driver set has always been more Intel friendly than AMD and VIA friendly.

Perhaps if you can get into safe mode, you can somehow set things up to install the proper chip-set drivers.


Collapse -

by shuja52 In reply to USB ports work until Wind ...

Your BIOS and as such motherboard is OK, the problem is with windows, which window u are using?

Collapse -

by shuja52 In reply to

Windows is not installing device drivers due to some reason, hire a PS2 kbd, start windows, as the windows works normal unplug the ps2 kbd and atach your USB kbd, it will be installed and work fine

Collapse -

by byron27 In reply to

Wowee, Working fine! been having the same problem for a few months and was getting really irratated!

Many Thanks

Collapse -

having same problem

by sdr984 In reply to USB ports work until Wind ...

I'm having the same problem. When I boot my machine I have an Interlink Versapoint wireless RF keyboard/mouse I'm using. Within the BIOS this works great (My mobo is a Asus P7H55-M PRO with Intel H55 Chipset). Then Windows 7 starts up and the fun begins. The keyboard does not work on boot. I can get it to work by opening the device manager (using separate mouse of course), right clicking on any device, and selecting 'Scan for hardware changes'. I'm not sure why Windows doesn't do this automatically on boot. Then when I restart the machine, I'm back to square one again. Has anyone figured out how to fix this?

Related Discussions

Related Forums