windows cannot start the windows firewall/internet connection sharing (ics)

By partheepan ·
Hi, i tryed to start the windows firewall in service, its shows "cannot start the windows firewall/ internet connection sharing (ics) service on local computer. error 5: access is denied". Its a network shareable system which has xp os with SP2.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

There are a number reasons for this

by Jesus_C In reply to windows cannot start the ...

You isp could a system in place which requires the firewall to be disabled.A trojan could have disabled it or if you have a third party firewall installed,this definately would have disabled it.

Collapse -

GP maybe

by EvilhomerGD In reply to windows cannot start the ...

It is entirely possible that Group Policy has the service disabled (assuming that the PC is a member of a domain). If it is not a member of a domain, it can still be disabled using local security policy (gpedit.msc). Also, just double check to be sure that you are an admin on the local PC as this might stop you from starting the service and it is the easiest thing to check. It could also be a setting for the service that was changed. If the logon for the service was changed, that could also pose a problem.

Collapse -

Check This Services

by rkuhn In reply to windows cannot start the ...

Check these services and make sure they are running, the windows firewall is dependent on them:

Network Connections
Remote Procedure Call (RPC)
Windows Management Instrumentation
Event Log

Collapse -

ICS usually isn't needed with SP2

by bobfells In reply to windows cannot start the ...

I had the same issue a few days ago on a XP Pro SP2 PC. I couldn't open the firewall setting via control panel or start that ICS service. The Microsoft documentation I read states SP2 XP PC's do not need ICS and this is adjusted when you install SP2. All I did to get past this issue was reinstall SP2. The SP2 install encountered an error during the process and made me reboot. However, upon rebooting, Windows went through the automatic update questions as if SP2 was successfully installed. I set up the automatic updates accordingly then tried to open the firewall settings via control panel and it worked. Good luck.

Collapse -

Same issue-none of suggestions fix problem

by rdencpa In reply to ICS usually isn't needed ...

I have the same error message re the firewall service as noted at the start of this tread but I have tried all of the suggestions and none of them will allow me to turn on the firewall. What is strange is that if I reboot then the service will be on for awhile but then something turns if off and then I can't turn it back on with the controll panel or the manage, services, start sequence.

Related Discussions

Related Forums