Question

HELP! Why won't my headset microphone work?

By willard189 ·
Just bought my dad a brand new Beexcellent GM-7 Pro Gaming Headset, and the microphone does not work.

The speakers work fine, and I can hear sound through the headphones. After trying to find a solution on the internet, I watched a video about the differences between 3/4 pin 3.5mm jacks. However, this doesn't seem to be the problem, as I have tried using an adapter (from 4 pin to 3 pin speakers/mic jacks) and plugging them in the green/red ports in my desktop, and still no success.

I have ensured that the microphone switch is turned on and the volume is turned up.

I have checked in the "manage audio devices" section of the control panel, and the only option is a Realtek(R) Audio microphone (which has NO sound coming through it), a Line-In which is "not plugged in" and a Stereo Mix which is "disabled".

There is one interesting detail; when I flick my microphone switch (on my headset) on and off, a spike of volume appears on the Realtek(R) Audio microphone. Nothing happens, however, when I speak into it.

Any help would be greatly appreciated!
Many thanks, -Will
1 total post (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

You may need to do trial and error

by markp24 In reply to HELP! Why won't my headse ...

Hi,

Does you desktop have an additional driver/control panel from the Audio chipset manufacture (like a realtec audio manager app?) may want to check for that, sometime the Windows default "sound" control panel app will not work.
You can also try the line in port for the mic see if that works, Also does your system have from and rear audio jacks? might want to see if the front ones work vs the rear. Otherwise it may be an incompatibility with the 3/4 headset jack and the plug from the headset.

Back to Hardware Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums